VCarve Desktop - This app can't run on your PC

Has anyone else received this message?

VCarve was working fine yesterday, and I shut the computer off for the night.

This morning, I started the computer and tried to launch the link from my desktop and nothing. I’ve uninstalled, reinstalled, and restarted multiple times at this point and always the same message. I found an update that was installed yesterday, so I uninstalled it and tried again and still nothing.

Vectric support is trying to help, but seems baffled.

Vectric believes it to be an antivirus issue. In part that is correct because for whatever reason, the antivirus decided that the EXE was a threat after having run for a month with no issues. Although after whitelisting the EXE and any other Vectric files, it still wouldn’t work.

I currently have a workaround where I can right click on the EXE and click ‘Restore Previous Versions’ and open from there.

Tedious, but at least it is working.

Just curious. Which Operating System are you using?


There was a news post I read saying some antivirus software was causing major issues with Windows. It is somehow thinking windows programs are actually a virus, most have corrected this issue already, so maybe a quick anti virus software update will fix it

It is the Webroot AV program.

don’t suppose you know how to use procexp.exe to get the pid that owns the message box?

No, I don’t.

It does seem that at least in part this is an AV issue. Although the message box that I am getting is from Windows.

Still working on this.

Can you not just add the Vcarve .exe to “trusted applications” or whatever your anti virus calls it, or add it to files that are excluded from being checked ?

I’ve had bother in the past when my antivirus incorrectly thought something was a threat and treated it as such, but I could always manually override this in various different antivirus software.

Edit- I should have read everything above more clearly…

Have you tried disabling your av and then running vcarve? Obviously only while you are using vcarve

I know that wouldn’t exactly be a “fix”, but may be a work around for now

It has been whitelisted, though not making a difference.

From the article that @JohnChamplain posted, ‘As this post was going live, Webroot’s cloud-based system for issuing commands to clients was unable to revert the quarantined files. Officials have yet to confirm they would be able to revert all the bad determinations.’

So even though they are whitelisted, they are still not working.

Which AV are you using? (hope it’s not Norton).

This article might help explain things;

Also, why not just revert to your latest backup?

Webroot, mandated by IT, so no getting away from that.

I hadn’t thought about trying to run system restore, for now though I have a work around. Hoping for everything to get hammered out.

Ouch :disappointed:

Perhaps post something on their forum so a tech can help address this issue for you;

No.3 here at least partially fixed my issue:

Now, however, every time I run VCarve, I get the box that says ‘Do you want to allow this program to make changes to your PC?’

Getting closer, but operational.

1 Like