Vcarve letter spacing problem

I did my first vcarve/v-bit sign yesterday and have some strange letter spacing issues showing up.
To get the typical questions out of the way -
I have the newer X-Carve so the only pulley with set screws is the Z-Axis/Acme, it is has blue loctite from the initial build a few weeks ago, it is tight, does not budge, both set screws in there.
Belts seems to be correct “pluck” sound - as best as you can adjust to the “precise Goldilocks setting” :slight_smile: , but checked and verified.
The stepper motors have been calibrated within the last two weeks.
Using the latest version of V-Carve and Easel.
I downloaded the file from VCarve using the Easel PP downloaded in the last week.
I used the Z-Probe during setup

Job settings:
Whiteside 1541 60deg V-bit-3F 0.25sh
Pass depth - 0.06
Final Pass Stepover - 0.0075 , 3%
Clearance Pass Stepover - 0.045 , 18%
Feed: 70ipm , Plunge: 15ipm
Used TT font Sylfaen - had never used that particular font before, but it had the look I was going for
Letter height: 0.31" - mostly because I was trying to make it fit on a last piece of oak I had, 11.25x17

I was hoping this would be a good presentable piece I could at least hang in my office, but also knew this was a “first attempt” and there could be some tweaking needing to be done - so ultimately its no big deal.

So the problem is the spacing that occurred between some of the lettering. I thought that maybe the 0.31" tall letters may be an issue, but it actually came out very legible.
The spacing issue is weird because probably 90% of the lettering came out correctly and did not have that issue?!
You can see the issue with the “and” put a space between the a and n, and then that pushed the next word together with the following word. Then the next one, its like there was extra space added between “lives” and “over” that made the word “again” have the a and i be squished together?
The toolpath preview in VCarve does NOT show this at all - and the toolpath preview you can see in Easel also does NOT show this - everything looks correct as it should.
I have triple checked the texts and there is definitely no oddball spacing, special characters, etc that could be in there causing this.
So could this just be a random glitch with how the TT font was interpreted in those sections, or some other issue in how the gcode was processed? Could it be a glitch simply due to it not being able to fully handle/process lettering consistently at that size?
I would greatly appreciate any wisdom you “gurus” could share on this! Thanks!
Sorry this was so long but I wanted to be sure I included every bit of detail I could think of that may help you come up with an idea.


It seems your either X or Y axis belts are a little loose. You better check your belt tensions one more time. Even you can check any missing tooth visually.
Also you may want to check Acme nut holding collar’s space if there is any. If you have up and down movement on Acme screw, that gives you inconsistent depth on carving. You can hold the screw up and tide the set screws, must be no space.
Still looking good job.

Thanks. I will check my belts again.

Just checked - belts are definitely good, no missing teeth found.
Nut and pulley on Acme are snug, no play. I wouldn’t think the Acme rod would cause an intermittent issue with lateral spacing anyway, but I verified it again anyway.

1 Like

That is one thing I have not done - advanced probe settings - and entering the exact thickness of the touch plate.
No, I did not plane the surface before hand, I do not have a planer, or a jointer, and also do not have one of the “planing” bits. :frowning:
Nothing to do with Z Axis would cause the spacing issue though, right?
Yep, previews looked exactly as expected.
So how/what do I do to resolve the lost steps?
As I had mentioned, I have done the calibrating of the stepper motors within the last two weeks and everything looked great then. Is there something else I can check/adjust?

Yes, I am using the dust collector from Inventables.

True - :slight_smile:

I have been pretty ocd at keeping all of the rails/belts areas clean of all debris.
That’s one item I forgot to mention in my initial post! I always give my v-wheels a quicl check before I start any job, they seem to be tightened appropriately? Based on everything i have read anyway… Another item like the belts that is a real pain since you can’t really have a specific setting/torque, etc. It makes me nuts to have variables like that where it is, “well, you want it just tight enough but not too tight” or “you want it tensioned just enough for a plang or a plink but you don’t want a donk!” :slight_smile:

I did the calibration as far as measuring out to 700mm on X and Y, I think 40mm on Z, and adjusted the GRBL based on that and the calculation formula. The X and Y were only off by approximately .5 or .75mm.
I have not made any adjustments to the pots, only the initial very slight tweak so they were set exactly as stated per the build instructions.

It just happens to be they are on different breakers in my garage/shop. But now that you mentioned it there were a couple times last night during the run that lights didn’t necessarily blink, but there was kind of blip? If that makes sense? Kind of like if the AC kicks on and causes a slight blink in the lights? We occassionaly do have what seems like “dirty” power in our area. Could those blips be just enough to cause a hiccup? That would make sense I guess.
Definitely will pay more attention to that in the future and see if that is the culprit.

Ok. Thanks very much, I will check into those things this evening.

1 Like

What does this look like in a G-code previewing app?

Often-times typefaces will render with odd spacing due to a line being spaced on the screen, then when re-drawn on another device, strings of characters will have their beginning character set to where the screen had them set to appear, but preceding ones will have been placed in their natural location, resulting in gaps such as you describe.

One way to get around this sort of thing is to convert all type to paths before output.

I second what WillAdams says. Convert the text to paths or shapes before VCarving. Different programs handle text differently. Once it’s a shape it shouldn’t have that issue.

1 Like

I created the project in Vcarve Desktop then exported the gcode using the Easel PP - imported gcode into Easel then ran it. In the preview in both Vcarve and Easel the text appeared correctly, no spacing issue, no problems of any kind.
I think at this point, until I get to run another similar project, I am chalking up to power fluctuations as discussed earlier.