VCarve making larger circles

I expect there’s a simple answer here but it eludes me.

If I want to cut out a simple .5" diameter circle in vcarve and use the profiling toolpath for an inside cut using a 1/8 endmill I wind up with with a diameter of .625… I would expect this size if I specified a cut on the vector but not inside. Calibration on the X-Carve is right on.

What am I missing?

Thanks in advance.

Measure the bit…some of mine are off…just a “bit”. :slight_smile:

Yep. Did that and its just a couple of thou small. Doesn’t appear to be the source of the problem.

In V-carve, do you have any offset set on the cut?

None, set to 0. Almost figured I’d add in a negative offset to correct but figured that might just be masking the problem.

Have you measured the axis movement? or adjusted the steps per inch settings in GRBL?

I checked axis movements and they are as good as it gets. Also I’m on a smooth stepper which seems to be working fine. Also my centers between circles are crack on as well. It’s only circle diameters that are off.

BTW, thanks for helping out here Erik

Anytime…not much help from me…I am truly at a loss.

You are exactly 1/8" off…did you accidentally choose a .25" endmill?

:wink: No, I measured the bit. It’s .124.

Only thing I can think is the bit is setup wrong in v-carve…verify that…then I have no idea.

Not sure how it works with vcarve. But if it is cutting ‘on’ the line. Then it will be exactly .125 off. Half the bit outside.

Just my .0000002 cents

Yep. If I was cutting on the line rather than an inside/left vector you’d be spot on. But I think I found the problem. It’s in the post processor I’m using from VCarve. I saw a recommendation to use the Mach2/3 Arcs (inch) pp which up till now was the one. Then I saw a recommendation that the standard fanuc (inch) is the right one, and now the hole diameter is just about 1/32 too large so I think this is the root cause. VCarve doesn’t have a Mach 4 (what I use) post processor so I’ve contacted Vectric to ask what the final answer is and once I find out I’ll pass it on. Hopefully this is going to be the solution.

It is certainly possible that an incorrect post-processor will cause scaling or truncation problems when outputting the toolpath data. You can verify this for sure using VCarve’s simulation. If you turn on the ‘Show 2D Previews’ & ‘Solid’ using the checkboxes on at the foot of the toolpaths tab then you can use VCarves drawing and measuring tools to fully examine the extents of the your cutting paths. If these are correct the problem is definitely ‘downstream’ - post processor,machine setup or machine/tooling problems.

If they are not correct the most likely source of the problem is the vector geometry, tool description or your toolpath settings (in particular unwanted offsets). Speaking from experience (and with some embarrassment!) I can confess that this has happened to me before when I have edited the geometry of a tool in my tool database, but overriden/not updated the tool’s name. In other words the tool name is ‘0.125" - Endmill’, but the geometry has been set to a diameter of 0.1" Doh!

Hope this helps,


THat happened to me when I switched from generic BOB to Gecko 540. I used to use arch inches and started getting strange and sometimes dangerous results. I switched to GCode Inch and it works like a charm. BUT and this is a big butt, I use Mach 3. Still it will be interesting to hear what they say and I will test their reco on Mach 3 as well once you post it.

I got a reply from Vectric this morning that they think the Mach2/3 Arcs pp should be fine but asked for more information if I was having problems. I have to note that my initial email them was just to ask for a pp recommendation for Mach4, this before I ran into these problems. So I followed up this morning with a more detailed explanation of the hole diameter problem and now waiting for their response. Following up on Earwigger’s comment I tried the GCode pp and got a slightly closer to correct circle, this one being now just 1/16" too large in diameter, like the Fanuc. I’m almost ready to plug in offsets to get on with this project but have a character flaw that keeps me from proceeding without getting everything dialed in perfectly… :smirk:

But also wanted to follow up on Edward’s comment about using VCarve’s measuring tools. I do have them Show 2D Previews & Solid turned on and can use the measuring tools on the drawing tab (where all the holes are just as I’ve specified) but I can’t use the measuring tools on the 3D view to measure the tool cuts. Am I misunderstanding or is there a function that does turn on measuring in 3D?

Thanks to all of you for staying on this.

Total bonehead move on my part. The root cause was that I didn’t have the bit properly defined in my Mach 4 tool table. Was paying all the attention to VCarve tool table and forgot all about making sure both tables matched. Once I fixed this all was fine, I’m using the gcode inch pp from VCarve.

Sorry for running us around in circles.


Here is a question from someone that has never used Mach 3 or 4 but is interested in learning about it.

What does Mach 4 have a tool database? Does Mach 4 generate tool paths? My understanding has always been that the the CAD/CAM software created the toolpath (based on tool geometry) and Gcode file. Then Mach 3/4 would simply generate the control signals required to make the stepper motors follow the Gcode instructions.

If that is correct then Mach 4 should not need to know anything about the tool being used.

Where am I confused?

I read everything with interest, learned a couple of new things, and was reminded once again to not get complacent and to check all of my parameters before running the machine. I’d say it’s a successful thread that doesn’t require an apology. :smiley: