VCarve to Easel

When I save my G-Code in VCarve I use the X-Carve post processor. I was working on a job and saved the roughing, finish and profile. I was able to open the roughing and finish pass but when I tried to import the profile I receive this message. The profile was a trace of a model, if I draw a circle and then save that as a profile using the XCarve PP it works in Easel.
Screenshot 2021-08-08 at 17-38-48 Easel - 606 endmill3D Roughing 1 gcode

Does anybody know why I’m receiving this message?
Now I did some research through the forums and learned a few things so I tried using the Easel post processor for the profile cut but it saves it as an NC file and not GCode file.
What am I doing wrong?
and if the NC file will work in Easel will the NC file work in PicSender?

Thank You
Russell Crawford

Hey @RussellCrawford,
The error is because the gcode contains an arc command… Easel doesn’t like arcs.
Can you send me the X carve post processor you’re using?

It should, yes.

1 Like

I’m using the one that was in vcarve. Then when i went to import gcode I clicked on vetric, downloaded the post processor and put it into a folder in vcarve. Is that the one you want? After I put the pp in the folder I was able to see the easel pp. I had to restart the program.

1 Like

Just downloaded it. There shouldn’t be a way for the arc command to get in there.
Can you share the gcode for that profile cut? Or at least the first 20 or so lines.

I will send it to you tomorrow when I get home.
Thank you

1 Like

I hope this works if not I emailed them to you Neil
Profile (69.6 KB)
.25 endmillProfile 2.gcode (63.4 KB)

The file looks like it was done with the Easel Post.

The gcode file, with arcs, was done with a different post processor.

1 Like

Yes the GCode file was done with the XCarve PP, the one I have always used to save my GCode from VCarve. My roughing and finish pass I could import into Easel, the profile I couldn’t import. That’s when I received the invalid GCode message. Here is the PP that Vetrics sent me in case someone else needs it.

In VCarve go to File, Open Application Data Folder, then put the Easel PP in the PostP folder


1 Like

So you used the downloaded from Inventables one (Easel) for the “” and then the X-Carve one for the bad file, and then Vectric sent you another version of Easel’s?
Looks like they messed up the X-Carve one on an upgrade. I would just pick one of the “Easel” ones and stick with it when using Easel.


yes,That one was already in VCarve

I’m going to try saving a file with the Easel PP and see how it works

They’re actually a bit different. The end result will be the same, but the one vectric sent you (“Easel Grbl (inch) (*.gcode)”) looks a little better.

1 Like

Oh, man this is confusing. Glad your here to help the cool kids out.
Edit: I corrected my other answer. Thanks again for your help

1 Like