Inventables Community Forum

View current z-probe height?

Yesterday I used easel for the first time in about a week. For some reason it lost all my machine settings. I setup my machine and added the Z-probe but when I started to carve it went too deep on the first pass. After some head scratching I removed the z-probe, went through machine setup again and using the advanced settings for Z probe setup I changed the probe height to reflect my actual probe. I was then able to carve without issue. This morning I carved again without issue, but then when I went to open the next job the website wouldn’t load. Restarted my machine, loaded the website, picked the next job and once again its carving too deep right out of the gate. Is there any way to see what the current z-probe height is set to? I can go and reconfigure it but I want to know if thats the problem before I commit to resetting my machine profiles every day.

I have had a similar problem of z going to deep. It happened after I increased the safety height.
It work good for awhile. After a few days not using the CNC, I used it and it went way to deep.
I changed the safety height back to the default setting and it seems to be doing better.

@Ben-Saks it was Andy’s issue that brought me to test those probe settings in the video i sent via email…

Hi Andy. Thank you for bringing this to our attention. We are looking into a resolution. I will update this thread when we have one. Just to confirm - are you using a custom z-probe thickness?

1 Like

I am, I purchased a pre-made z-probe off amazon and measured it with calipers before using it, it came in at 14.09mm which is what I originally set it to. It worked fine from day one, right up until you implemented this new profile thing.

Maybe I wasn’t clear enough in the FB reply…
When a custom thickness is set in the machine profile it appears to only be retained until the user swaps profiles or unchecked and recheck probe accessory in the edit machine screen.

When I set a custom probe and didn’t swap machine profiles, or mess with this checkbox it would keep my custom probe thickness, any time I did either of those 2 things it would revert my probe thickness to the 14.99mm default thickness… you can test this by probing, then backing out of the carve screen and looking at the current z position in machine inspector…

It should indicate a z location of your probe thickness plus 6.35mm. If its reading 21.34 then its reverted back to that default of 14.99 for the probe thickness and your z will be off…

Over on YouTube prior post Ben Saks replied and said they were looking into fixing the issue… I sent him a video about the issue so I’m confident it’ll get resolved pretty soon & he’ll reply to that other thread to indicate when its fixed :+1:

Until then I suggest using a dedicated gcode sender in order to use any probe that’s not 14.99mm thick :man_shrugging:

How do you adjust the z-probe height?

The probe thickness can only be set during the machine setup. You’d need to go through the machine setup again and at the probe testing page there is a place to enter your custom thickness, but it might be in the grey “advanced” button at the bottom of this screen, I kinda forget. But its definitely at the page where your testing the probe :+1::+1: