Wait for spindle to spin up after resume from pause?

I’ve setup a spindle controller to start/stop the spindle from Easel which works as advertised. When I pause a job, the spindle spools down like I would expect. This is handy to adjust workholding, etc.

Upon resume the spindle is started and the cutting path is immediately resumed. Unfortunately, this doesn’t give the spindle any time to spin up before resuming the tool path.

Is there any way to insert a delay for the spindle to return to speed before resuming the cutting path?

Just broke a bit and damaged the work as a result of this :frowning:

Are you using Easel for toolpaths and as a sender?

Yes, Easel for both.

Can you capture the log when you pause and resume?
Are you using a physical freehold switch or the controls on the screen?

I’m using the controls on the screen, so simply hitting pause and then start again.

Here is the log:

[MSG:Restoring spindle]
G4 P0.1
G0 X0.00000 Y0.00000
G1 Z0.15000 F12.0
G1 X10.00000 Y0.00000 F4.0
G1 Z-0.05000 F12.0
G0 X0.00000 Y0.00000
G1 Z0.15000 F9.0
M3 S1

Just to restate - this is in fact working, but the problem is that the spindle start and motion resume happen at the same time, leaving no time for the spindle to get up to speed before moving it again. The log doesn’t have timestamps, but that’s what’s happening.

Grbl has a safety door parking feature that will do what you’re wanting, but I don’t know that you can get the same behavior from the on screen pause.
So, you hit pause and the machine stops the spindle then goes to zero? When you issue a cycle start cutting resumes before the spindle has time to reach the needed rpms.
Can you start the spindle before you resume? What kind of spindle?
Can you post your $$ grbl settings?

I’m pretty new to all of this and am running bone-stock everything with the exception of wiring up a relay for the spindle motor (not speed control, just on/off). I also added another relay on the flood coolant output M8 which controls power on/off for my dust collection.

When I hit pause, the machine stops moving all axis. Spindle shuts down, dust collection keeps running. When I hit resume, both the machine axis and spindle start again simultaneously.

Using Easel, I don’t see any means to start the spindle before I resume, which is why I’m asking about how to make that happen.

Just learned how to do the $$ thing, here’s what it tells me:


You have a laser?
Change $32 (laser mode) to zero by sending

That will affect the spindle ramp up.

Nope! Just a Dewalt 611. Apart from the relays for the Dewalt and the dust collection this machine is bone stock.

It was however purchased used, so it’s conceivable that some saved setting carried over from the previous owner.

I added to my last post while you were typing. Change the $32 value to zero.

1 Like

OK $32=0 does change the behavior: the spindle no longer stops when paused. Spindle control at the beginning and end of the job still works, but it’s not putting the spindle into a safe state when using pause/resume.

I can probably override that by manually hitting the power switch on the spindle itself.

Use the physical switches for pause/resume. What happens?
Feedhold is just that, it stops the feed. That’s what happens when you issue a ! by pressing pause on the screen. Your router is not intended to also stop.
Like I said, you can set it up to do that with the physical switches.

1 Like

OH THAT IS PERFECT. I had to go lookup which buttons did what, as I’m still pretty new at this machine. The pause button on the X Controller is exactly what I wanted, it raises Z to pull the tool out of the way, stops the spindle, and upon resume starts the spindle before returning to the cut.

THANK YOU @NeilFerreri1, you’re a life saver!

1 Like