Was about to sell the X-Carve... when

First a little back story…

I bought the 1000mm x-carve in 2015 as I wanted to get into some simple CNC type work. I built the thing and put it on the dining table where I then did my first project… A simple sign that said my son’s name as a test. I did this in MDF, needless to say my wife went beserk when we both saw how much dust went everywhere. Still Project 1 was a success…

I moved the XC into the garage and started project 2… a logo with various depths and some medium complexity. I was only using Easel so nothing too crazy. This time I didn’t get the same level of accuracy that I had seen on Project 1, so I consulted the forums and did all the usual belt tightening, voltage testing and project 2 eventually came out okay.

The I got busy at work (Suicide Squad vfx) and wasn’t able to spend any time on it for a while… When I did come back to it about 3 months later, I tried to carve the Suicide Squad logo (Project 3), but after 4 attempts, I was back to the forum to ask more questions! Eventually after many weeks of tinkering, I got an “okay” print that was only good enough for my garage, and no where else. A friend who has a 500mmXC suggested my waste board wasn’t level and that I should invest in an aluminum one, also that my x-axis should be strengthened. I didn’t do the first idea, but tried the second. Fail.

So began the next 12 months of a hate/hate relationship with the XC. I couldn’t get a single thing to work well. One of my axis would just go haywire in the middle of a print… No matter what I did nothing helped. Then the upgrade came out to the x-controller… I figured that something in the original design on my specific parts was wrong and that the upgrade might magically fix it. So… after 18 months with the XC and only 3 projects to show for it, most naff… I was doing a hail mary upgrade in the hope it would work…

Upgrade complete… plug it in… now there is a problem with my OS on my mac not seeing the XC, even though the OS is supported… Turns out (thank you John Hayes at Inventables) that there was a conflict with a Wacom driver that I had installed. I got everything ready… by this time I had 18 months of ideas back logged ready to go…

Still didn’t work… infact, the problem seemed to just go wrong more powerfully now… Mid carve… brain fart… carve and wood ruined. The local wood shop loved me buying this device as I’ve sunk over $1000 easily in to wood that would just become scrap almost instantly…

Okay… went back to forum, asked questions… brilliant people there gave me suggestions… nothing worked. Nothing.

The problem would occur 100% of the time, at a random point in the first 25% of a project. Belts had been tested at every possible level of tightness… the voltages had ranged from 0 to 17 French Nuclear Power stations, but still nothing. I had a priest bless the thing and a blind shaman gypsy cast a spell on it with rotting heather and a elephant tusk. That rat bastard machine still didn’t want to make anything but bird nests.

I was aware from all the trawling on the forum that I was not alone… there were two camps… those smug barstools who seemed to have it work right out of the gate and then every time since with a modicum of tweaking etc… and then the group I was in… the zombie, forum lurking semi-deads who spend all weekend, a slow lingering divorce from their wives / families as they try to figure out why they have spent $2000 on a lemon.

Which brings me to this weekend.

[most long winded and boring post ever I know, but if you’ve made it this far congrats, almost done]

I decided that if I didn’t have it working by Monday morning, I was going to either sell it, or scrap it. Figured it would be hard to sell if I couldn’t say it worked… so had resigned myself to just going “Office Space” on it in the garden like they did to the malfunctioning photocopier in the movie… At Least I would feel like I’d finally beaten this metallic foe, if only with a sledge hammer. I would then post images of this “fix” on the forum as a final goodbye.

That was the Friday plan for Monday. I didn’t sleep much thinking over all the steps I’d done to fix the thing. I hit the forum late Saturday night after a day of failed tests again, and came across a couple of comments about the x-motor shaft screw thread that holds the belt wheel thingy… See picture:

This thing grips on to the the flat surface of the motor shaft and moves the router back and forth. I had read that in some rare cases the motor shaft did not have a flat area for grip and that had caused problems… I checked mine and the shaft did have the flat area. I was a bit annoyed as this would have been an obvious problem for slipping. But it seemed fine. Then I saw it… The little screw that threads in there and connects to the shaft was not there. MIA it would seem. Could this be it? I remember the forum mentioned at some prior trawl, that you should use loctite on the screw to keep it in place… I hadn’t, it didn’t.

Depression at the loss of the little threaded screw had me searching my nuts and bolts collection for a similar thread. I had nothing. I figured I just see if by some miracle it had fallen somewhere and got stuck. I store my whole XC on a folding table on the wall, so chances it was still around and not sucked up a dust shoot was remote. However… looking under the belt I found it:

At this point I let out a loud series of rude words. Being English, many of them were rather disgusting and involved putting objects in other objects that don’t normally contain objects. Followed by an alphabetical hodge-podge of general swearing etc.

Could this be it? The Holy Grail of my problems was down to this little screw coming out 18 months ago, and resting quietly under the x-axis belt until such time the meat prop that owned it could muster enough brain cells to figure it out?

I rushed off to the store and bought some:

…and put the whole thing back together…

Now Sunday afternoon, I created a quick file to test it:

It was strangely appropriate… A Coast Salish piece of art that depicts a Beaver… a symbol of learning and education… Something that I figured had had to happen to me for this to work. I hit that green carve button and sat back and watched in ABSOLUTE GLEE as it carved it out perfectly from start to finish over about 3 hours.

Maybe it was a fluke?

Maybe this was the XC God just F87king with me… so I went to do a simple logo in some scrap 3mm aluminum…

Nope… worked perfectly… (I did however make the tabs too deep but that didn’t matter!)

This is a logo keychain for the current movie I’m working on Kingsman 2: The Golden Circle. It came out great.

So… it’s Monday. I still have the XC and I wouldn’t now sell it for the world. I did two carves yesterday and they turned out great. That’s almost the same number of carves that I had done in the last 18 months. I plan on several more this week, and though I know that “yes” no doubt I may have an issue or two in the future… I feel that sticking with it really did pay off in the end.

So… to all those out there who have an XC and think they have tried everything… it can come down to a tiny simple screw the size of a grain or rice as to whether this whole machine will work or not. It does seem like something like this should be redesigned to avoid having it be such a catastrophic point of failure, but for now… I’m just going to make some dust, and enjoy the XC… finally!


Fabulous story, sorry about your troubles and I felt your pain :stuck_out_tongue_winking_eye:

Congratulations Mark! Glad you got it going.

I replaced my grub screws with these from McMaster:
18-8 Stainless Steel Thread-Locking Socket Head Screw M3 x 0.5 mm Thread, 8 mm Long

They’ve got a nylon patch on the side to act as a thread locker. They use a much larger hex key to tighten, so you won’t strip them (or the key). Major upgrade that doesn’t cost much.


Wow, awesome story lol it was long but I couldn’t stop reading. Has anyone destroyed their xc before?

Lovely story and I just watched the first Kingsman last night (been on the list for awhile) and I’m hoping the 2nd will be awesome.

Those two projects are amazing and hopefully you’ll make plenty more and also share the pictures as well!

I did what @StevePrior did as well. Not only is the patch acting like a thread locked, they’re also visible so you know if one goes AWOL.

The new Xcarve 2.0 has pressed on pulleys for every pulley except the ACME rod. So they fixed it for 4 out of the 5 pulleys on the machine. Now they just need to do a linear Z axis and remove the Z axis pulleys all together :slight_smile:

1 Like

Thanks Erik. I’m on idea catch up now!

1 Like

Cheers Steve… I will order some

Awesome story. You should be a writer! Or, maybe you are?

Now go make your wife something since you’re now married to your X-carve!


Thanks Jason! Yes, I owe my wife big time while I was in the garage scratching my head, and while I was in the house in a grumpy mood!

Darn after skimming what you wrote lightly I was going to ask you if I could buy your controller.

1 Like

I wish they sold the feeling you get from first success in a bottle…


I will say that if you routed MDF on the dining room table with I assume no dust collection, and you’re still legally allowed in the house - you’ve got a VERY understanding wife.


I replaced my set screws with machine screws because I had the same problem, one of set screws had fallen out and the other one had become loose. I don’t think the set screws are long enough that come with the kit to actually get enough bite when they are all the way tight and eventually come loose. My Z axis and my x axis was having the same problems so it was hard for me to figure out because it was slipping in multiple directions and never had any consistency. Loctite with longer set screws or bolts is the way to go. I had a similar story of once in a blue moon having a successful crave and had gotten really annoyed and disheartened with the XCarve. Hope your post will help others too!

I always come to the rescue.

Congrats on solving the mystery


Set screw… where arrrrrrrre youuuu?

Oh, there you are.



ditch the set screws for cap screws


+1. Cap screws were one of the best changes I made. The tiny grub screws were too fragile and caused bad language…


Thank you, thank you thank you!!! Been tearing my hair out with a similar problem. Looked at the pulley that drives the X axis NO GRUB SCREWS!!! Fitted screw today and now it is working perfectly. My turn to be a smug successful user​:joy::joy::joy::joy:


Here is my test, worked perfectly.
Google Photos

1 Like