Way Off on Settings

I have reset everything in my X-Carve settings, but when I go to carve, my machine shoots across my carving area to another area, and starts the carve there. I have uninstalled and reinstalled easel. I have no idea what to do. Since an attempt to install a laser, the xcarve has endured all kinds of issues. Does anyone know what I can do to get this fixed?

1 Like

It is obvious that the machine lost the x,y,0 position. Is the machine calibrated?

I think it’s calibrated. All of the settings sent to me by Inventables are right on. I’ve homed it and everything. I don’t know if there are any further calibrations needed. If there’s something I need to do to calibrate it I’d like to do that.

Now when I go to use my Z-Probe, the Z-axis moves up instead of down.

I got it working, but the Z-Probe is the issue now. Just need to get that fixed. It seems when I get it fixed, my settings jump off.

Can you copy and paste your $ setting here?

1 Like

Time to look at your setting. The probe also. The correct thickness is crucial to be correct

Here are my settings. Everything carved well, except I had a line in my 3d carve. I think that would have been avoided if my Z-Probe had been working.

  • $132=100.000
  • $131=790.000
  • $130=740.000
  • $122=50.000
  • $121=500.000
  • $120=500.000
  • $112=500.000
  • $111=8000.000
  • $110=8000.000
  • $102=188.947
  • $101=40.000
  • $100=40.000
  • $32=0
  • $31=0
  • $30=12000
  • $27=1.000
  • $26=250
  • $25=750.000
  • $24=25.000
  • $23=3
  • $22=0
  • $21=0
  • $20=0
  • $13=0
  • $12=0.002
  • $11=0.020
  • $10=115
  • $6=0
  • $5=0
  • $4=0
  • $3=3
  • $2=0
  • $1=255
  • $0=10

You can change your$22=0 to $22-1 and i think you said you were attempting to use a laser. In that case change your $32=0 to $32=1.

When I changed $22=0 to $22=1 the machine will not home and I cannot move the machine at all through any axis.
For a reference, here is where my machine is at when homed on the X & Y Axis, and touching the material.

Those were the only 2 i saw that were different. What program are you running for the laser and did you change anything in it?

I was running Lightburn. I ended up having to uninstall it, reset easel with version 3.18 and then reinstall version 3.20. I initially had some problems with the z-probe, i just turned the x-controller off and then on and the problem was fixed.

1 Like


I installed a laser and use lightburn as well. The issue is likely that lightburn expects a different X,Y home than Easel does (top right vs bottom left).

There’s a few settings you need to check on Lightburn, that are specified in the jtech link above.

I also created macro buttons in Lightburn to go from CNC mode ($$ settings) to Laser Mode.

Lastly, I fumbled with it a bit but was never able to get Lightburn to home my Z properly. Maybe I need to add an invert Boolean to the Laser Mode macro. Regardless, my current setup has me disconnecting the Y and setting laser height for my project manually. It’s a decent 90% solution.

I think the reason it functioned normally after resetting the XController is that the changes to your $$ settings reverted.

Good luck, I’ll post my laser mode macro from Lightburn if I get a chance later.