Well here I go again

While I know that many of you have absolutely no problems with UGS, it has been a complete pain in the ■■■ for me.
Freezing up, moving in English and showing metric numbers, showing English numbers and moving in metric.
Having to shut it down and having to restart, etc. etc.
So after reading about all the success that many have had with picsender, I thought I would give it a try.
This morning I made the wise decision and downloaded the trial version and I cannot get it to work.
It is basically doing the same thing as UGS.
So now I’m starting to question my X controller.’
Anyone have any thoughts?

Thanks for the reply.
I know that your one of the people that really likes picsender.
I use Vectric desktop and the Xcarve post processor. (in inch mode)

That’s interesting, because I have used Easel also, and with the same results using UGS.
This morning when I tried picsender, the machine would not even move.
That’s why I’m starting to wonder about the controller.

when I open it up, I do get a positive feedback.
if I hit the home button, it will go home (but VERY slowly)
after it is home and I try to jog the machine, it will not move.’
I have tried all 3 axis and nothing.
the controller does however make one “click” when I hit the button.

I am new enough to all of this (~6 months) that I don’t even know how to do what your asking.

I would love to try Easel again.
But I cant even get the machine to jog.

The machine is currently running. (with UGS)
But I will certainly get back to you when I can.
I appreciate your help.

The Grbl Set button in PicSender will display the grbl settings also.

1 Like

So I just started picsender again and the same thing nothing.
I open it up it recognizes the port, and then nothing else works.
entering $$ does nothing and hitting the Grbl button does nothing

sorry, I was clicking the wrong button.
Grbl “SET” does work.
And now entering the $$ command also works.

this is the display.

$0=10 (step pulse, usec)

$1=255 (step idle delay, msec)

$2=0 (step port invert mask:00000000)

$3=4 (dir port invert mask:00000100)

$4=0 (step enable invert, bool)

$5=0 (limit pins invert, bool)

$6=0 (probe pin invert, bool)

$10=115 (status report mask:01110011)

$11=0.020 (junction deviation, mm)

$12=0.002 (arc tolerance, mm)

$13=1 (report inches, bool)

$20=0 (soft limits, bool)

$21=0 (hard limits, bool)

$22=1 (homing cycle, bool)

$23=3 (homing dir invert mask:00000011)

$24=25.000 (homing feed, mm/min)

$25=750.000 (homing seek, mm/min)

$26=250 (homing debounce, msec)

$27=1.000 (homing pull-off, mm)

$30=1. (rpm max)

$31=0. (rpm min)

$100=40.129 (x, step/mm)

$101=40.047 (y, step/mm)

$102=188.527 (z, step/mm)

$110=8000.000 (x max rate, mm/min)

$111=8000.000 (y max rate, mm/min)

$112=500.000 (z max rate, mm/min)

$120=500.000 (x accel, mm/sec^2)

$121=500.000 (y accel, mm/sec^2)

$122=50.000 (z accel, mm/sec^2)

$130=540.000 (x max travel, mm)

$131=540.000 (y max travel, mm)

$132=100.000 (z max travel, mm)

Well yesterday was quite frustrating for me.
After not being able to get picsender to work I went back to UGS.
Along with the normal problems, now the viewing window in UGS quit working also

You are homing so slowly because of the $24 setting, Change that to at least 250 so the machine will move a little faster. Definitely stick with one software package to troubleshoot and make changes to your settings. (Easel has good troubleshooting capabilities in the advanced section).Don’t keep changing which software you are using as it only complicates matters.

thank you for the reply,
I have been having so much trouble with UGS that I thought I would try something else.
I have been reading good things about picsender, so I downloaded the trial version yesterday morning…
However, cant even get it to jog.
That’s why I was starting to wonder if I may have a problem with the X controller.
Just to give you a little info about me.
I am nowhere close to knowing anything about CNC and or its programming.
6 months ago I didn’t even know how to turn one on.
Its been a steep and sometimes frustrating learning curve for me.
But overall I’m having fun with it.

I am not at all familiar with the Grbl settings or what they mean.
As far as the display, yesterday if I click on the “viewer” the correct file would eventually pop up, but the curser / tool would not move and the progress would not animate.
I’m using the latest version of UGS (I think its 1.0.9)

As far as the cable goes, I was going to replace it with what I thought would be a better one, but the person at Micro Center told my wife that the one that I have is better than anything that they sell.

I’m not at the machine now so I cant post any screen shots.
But I can this evening.

This happens when you load a file that is English and your trying to jog in metric.
Just make everything metric.
Also if you are using the zero block. Make sure that is in metric too.
even if you set it to metric and you load g-code for the zero bock in standard it will set the machine to standard disregarding the metric you have set in the interface.
UGS is dumb like that.

Everything I do is in standard.
but for some reason, UGS will simply make metric moves.
Sometimes I will click the metric button and make one jog and then go back to the English and all is good.
It doesn’t do it all the time and it may or may not do it with the same program that I’m trying to run.
Sometimes I can get a job all set up just to click the send button and the machine will move ~1/8" and freeze up.
Then I have to start all over by shutting UGS completely down, then open it up and to through the complete setup procedure again.
Other times it will work perfectly.
VERY VERY frustrating…

If you mean “alarm” by the red bar showing up, then no, there are never any alarms.
The screen just freezes and there is nothing more that I can do with it.
It actually freezes to the point where I cant even click the close button.
I have to go the black (I believe its the DOS screen) and close it before the other control screen closes.
I can at that time start over by opening up the program from scratch again.

That’s interesting.
What could be the issue with my computer.
Its a Sony laptop with windows 10.
I have the power setting changed so it will not go to sleep while plugged in.
I really don’t want to buy a new laptop.

So I am at this moment doing an “air” cut using the UGS nightly build.
So far it is performing flawless.
Now I need to see how it reacts with Charley’s Triquetra.
I’m going to do this right after this program runs out as that was part of my fits also.
I have to mention that Charley was good enough to spend a lot of time with me to try and sort this out.
Thank you Phil for the information.
One question.
Because this is the “nightly” build, do I have to reinstall it periodically?

The visualizer even works again.


I don’t know Phil.
Now I’m

getting this.