What am I doing wrong here?

I am wanting to cut a groove out on a cutting board but when I run the gcode, instead of the machine moving to the starting position to begin the carve, it wants to just drill striaght down into the wood and i have to abort it. It runs fine when I do other projects so I don’t know why its not wanting to work right on this one.

I use Vcarve desktop, here is a link to the project file.

Xcarve is the 750mm model

Thanks in advance

Update: I think it might have something to do with the thickness maybe… I ran a test, before carving i removed the board and ran the code and it lowered down to where the tip of the bit was just 1/2 inch from the wasteboard then it started doing the job… even though I have it set as 1.5 inch thickness, its acting like im still cutting into a 3/4 inch wood.

Most likely you have a G28 code in the beginning of your exported gocde file.
Either set a G28 parking spot for your machine (Homing switches are a prerequisite) or disable (in Vcarve) the G28 ammendment.

G28 command is a “touch this point before start carving”, and if not set often happen to be below cut surface.

according to the log, the first code is G90 followed by T1, G17, G20.

Can you share the gcode?

sure, here it is.

How are you setting your Z zero?

I use the probe that came with the kit.

How much room do you have to raise your Z?
Are you using Easel?

The machine is all stock, I run V carve Desktop 9.5. It raises plenty high in the home position. I dont think the problem is the machine itself, but something in the software. I am gonna run a test tomorrow on a piece of 2x4 which is the same thickness and see how that goes. I did a couple carves in the past on a 2x4 with no issues. I am also going to try using version 8.5 to see if there is a difference as well.

The gcode looks fine. I’m wondering if you are retracting too far before the carve. That could cause a crash and loss of position. Your machine might “think” it’s higher than it is and plunge too far.
Are you using Easel to send the gcode?

im using universial gcode sender to send the gcode. I think ill try easel to send it and see what happens.

It worked with easel but now there is another problem. When the machine goes all the way back then comes back forward, the left stepper motor cable stretched and disconnected and pretty much ruined the project…

update: Fortunately I was able to correct the job using a plunge router. Now I think I need to take apart the wire channel and try to fix that issue. When I slide the gantry all the way back then all the way forward it pulls the connector out of the motor.

I fixed the disconnect issue and I now discovered what is really going on from the original problem. So say I ran a carve on a 3/4" thick piece of wood using Universal Gcode Sender. My previous carve was also on a 3/4" thick piece, it will work perfectly fine. However if I use a different thickness say 1 1/2" thickness, the machine still thinks i’m trying to carve into 3/4" even though according to Vcarve desktop, its supposed to be 1 1/2", causing it to plunge way too deep. So if I fire up Easel, and reconfigure the machine to 1 1/2" using the probe then go back into UGS, it will now carve fine on a 1 1/2" thick. How ever if my next project is say… 1/2" thickness, I would have to go back into easel and reconfigure the machine using the probe on 1/2" piece in order for it to work right. Its as if the software is not telling UGS to change the thickness setting of the project.

The material thickness doesn’t matter (side from through cuts). If you set zero, correctly, at the surface of the material, that will be your reference. Your cut is at Z-.25". It will only cut a quarter inch below your Z-zero, regardless of material thickness.

Is your machine moving in all the right directions when u jog to the right is pos numbers to the left is neg front is pos back neg and up is pos and down is neg in the zed axis.?..

The machine will jog as normal. First Ill make the machine return to home position, while its doing that ill load in the gcode file. Then ill lower the z axis down to about 1/2" above the probe. Ill run the probe macro command, it will slowly go down until it touches then stops. Ill remove the probe and set it aside, then turn on the spindle and run it. But like I said, if I carved a 1.5 inch thick material last time and then carve a 3/4 inch this time, when I run it, it will raise up then move to position and start cutting the air above the material. However if I go to easel then set up machine and then go back to UGS, and do the exact same procedure, it will carve just fine. Would like it to work without having to log into easel in order for it to work right.

Are you probing in ugs?


What’s your probe macro look like? Maybe there’s an error there.

G38.2 Z-1.000 F1.000

Sorry for late response, I been busy. This code always worked before so I don’t know what the deal is unless something changed that I am unaware of.