What software have you used with Shapeoko2 besides Easel?

I have just downloaded and am working my way around Autodesk Fusion 360. Has anyone used this with the Shapeoko? I don’t even have my machine yet but I’m looking into more robust types of software…

What do you mean by “robust”?

I have used HSMxpress and Solidworks on the Shapeoko and it has done everything I have asked for in 2.5D so far. I am switching to a Planet-CNC driver board shortly over my TinyG board I use now. This keeps the tool height sensor and also keeps the warping corrections working from the TinyG which I use to PCB trace routing. But I have used Meshcam with good success for CAM, though hands down I like HSMXpress the best.

What is it you are trying to do with the software? Are you looking for a CAM or CAD software or a CAD?CAM package? What controller did you get with your Oko?

What version of SolidWorks do you have and where did you get a hold of it?

Some of our customers use Fusion 360. There is a built-in post processor for Shapeoko2 (and X-Carve, they use the same one) in there.

I’ve used V-Carve Pro and Aspire a lot. Those are pretty sweet.

I’m about to start experimenting with using a script that will export directly from the Eagle PCB design software, for milling circuit boards. I suspect that will take some fine-tuning but some people report success with it.

But I will say, Easel is pretty good for 90% of most jobs, and it’s dead simple to get started with. Sometimes the easiest tool to operate is the best one, depending on what you’re doing.

1 Like

I have an old workstation from an oil valve shop here in Houston which has Solidworks 2014 on it. I traded a week of product photography for it. The shop owner balked at my prices, we came to a deal on one of his old workstations with SW on it.

I would look into Flatcam for your PCB work. It is a free program which is very actively being worked on and has a ton of great features. It outputs gcode that will run on the OKO with ease. It handles the trace paths and also drilling with ease. I have been using it for about 6 months and never really had an issue. It still amazes me it is free.

That’s cool, I’ll check that out!

Has anyone used ArtCAM express with their Shapeoko? I found it online and the tutorial videos for it look very good and it is only $149. Seems to good to be true.

Hi @AllenMassey, I have seen worked with some customers who use ArtCAM. There is no post-processor for Shapeoko so you kind of have to mess around with the code. The easiest way (I have been told) is to export the gcode with the Mach 3 post processor, open the gcode in a test edit program, and delete the first paragraph of code. The code in the beginning is sending commands for features that that shapeoko doesn’t use. The you should be able to send the code to the machine with Universal Gcode sender, and it should work fine.

The same process should work with X-Carve as well because the electronics are the same.

Sam :palm_tree: :sunglasses: :palm_tree:

I’m using inventor with hsm. Works great, and I’ve used fusion 360 as well, also great. I didn’t want to learn new software so this worked best for me. So far my record is 30 minutes from starting a sketch to having a simple completed part.

Estlcam Great CAM program at third of the cost of other CAD CAM!

Most of my design work has been for 3D printing but my office has an X-Carve on the way so I went and tested using Fusion 360 at Pumping Station 1 on their Shapeoko 2. It was pretty easy to learn, my parts came out dimensionally accurate and, best of all, for a hobbyist like me, F360 is powerful and inexpensive.

The only thing I never figured out in my small few hours of printing was how to make the tool retract while moving to the first work position. I expect that to have been ignorance on my part.

Most of the time I use InkScape, MakerCAM and UGS.

1 Like

I just downloaded the GRBL Controller 3.0 to see how it performs as a replacement for the Universal Gcode Sender.

Unfortunately when I tried to test the new controller my Z-Axis went all zonky and the motor is not able to turn the threaded rod, even though when I try to turn it manually there does not appear to be any more force required than usual. I had been having some issues so I am pretty sure it has nothing to do with the GRBL Controller (UGS is producing the same results).

So now I get to take the Z-Axis apart again and try to figure out what is going on. I will be so HAPPY when the new X-Carve upgrade kit arrives with the new Acme rod! Hopefully that will be the end of these problems.

Inkscape - Makercam and UGS has been my path as well so far, but with Estlcam only being $50 and free to try. I downloaded it to test out.