When homing Z with UGS machine stops before reaching switch

So I’m getting ready to try and start using Fusion 360 generated toolpaths with my X-Carve. Before I did that, I was going to home my machine and then set the G28 location. Homing always worked perfectly in Easel, so I wasn’t expecting any problems.

At first UGS gave me a “feature disabled” when I tried to home, but some googling helped me get that fixed. Now when I send the $H command, the Z axis travels to within about 1/4" of the switch and sits there humming like it’s stuck. If I trigger the switch with my finger, it continues homing X and Y successfully.

So the weird thing is, if I jog the machine up in Z with the UGS machine control buttons, it will go all the way up and trigger the switch, no problem. Any ideas what could be happening?

Have you adjusted the current limit potentiometers?

Moving commands use a different velocity than the homing cycle. If your current limit is boarder line low then moves would be ok and homing might fail.

Don’t know why Easel works and UGCS doesn’t. I don’t know much about the Easel implementation.

Which version of grbl are you running?

Now that I think of it, I haven’t homed it in Easel since upgrading to the DeWalt. So increasing the current on the Z stepper may work.

That did the trick, along with a bit of silicon lube. Thanks!

1 Like

How do you increase or decrease the current potentiometer thingy?


Gen 2 I guess. I just go the machine in December last year.

Yes, it had been working just fine in Easel all this time. But don’t know when it’s trying to go pass X limit switch in UGS. I’ll try home in Easel to see if it’s UGS issue or limit switch issue.


It’s not a duplicate request as the other post was regarding current limiting and my x-carve is newer so it does not have the same problem.