Where is the Logic Switch?

Where is the LOGIC switch on the power supply?
Why isn’t it properly marked?
Why doesn’t inventables show a photo of it in the assembly instructions?

not that I have ever found. my first generation controller had that little toggle switch marked “logic” but nothing like that on the X-Controller.

1 Like

Thanks for the replies. I am connecting the IOT relay to turn my spindle off and on. The “instructions” say the "LOGIC switch must be on. The latest most up to date instructions.

Inventables verified there is no logic switch on the new xcontroller. So back to trying to figure the thing out.

“G”

“Band if little elves”

ROFLOL! :smile::smile::smile::smile:

Hi @AngusMcleod and @GaryScurlock we have 2 ways you can alert us to adjustments that need to be made to the instructions:

  1. Use the HOTJAR feature (little red face, bottom right) to draw the issue to the attention of the Inventables staff

  2. If you have or create a github account you can make a change yourself and send it to the team for review as a pull request.

The team that works on the instructions is @GriffinDennis and @JohnHayes they put a lot of time into updating the instructions last quarter. Yesterday they gave an update that they have additional time allocated this quarter to make additional improvements.

It is an ongoing project for them and they want to hear your feedback so they can continually improve it.

And THAT is why we all like Inventables…

2 Likes

@GaryScurlock I apologize I didn’t scroll up and read your original post. That’s my mistake. It is true that we have new switching power supplies. I don’t know the answer to your question. The person that knows the answer to your question for sure is our electrical engineer and he is out of the office today. Please send a message to our Customer Success team or call them at 312-775-7009 they will either know or can find out next week.

Can you link to the instructions you’re using for connecting the spindle?

It’s VERY straight forward on the Xcontroller. You connect the spindle (pwm) to the IOT dc input and the GND to the other DC input terminal. That’s it.

You can re-run Easel setup to tell it you have an automatic spindle to have Easel prompt you. Otherwise, you need to implement M3 and M5 commands in your post processor.

1 Like

I used the current instructions as provided on the Inventables website. I contacted Inventables and they verified that there is no “logic” switch on the power supply so they have to update the instructions. I said this in my second post on this thread.

I also verified on the phone with very helpful Inventables staff that something is wrong with my power supply board. We uploaded the latest GRBL firmware and tested the output of the power supply terminals for switching the IOT relay off and on. Inventables is sending me a new power supply board and I will try it out.

Thanks for all of the replies, everything is fine, nothing to see here, please move along.

“G”

For the record, the reason I ask about connecting the spindle is if you go to the current instructions:

http://x-carve-instructions.inventables.com/1000mm/

There’s nothing about wiring a relay into the system at least that I can see.

I was generally interested in what page you were reading due to that.

Sorry for trying to help.

And an unsolicated helpful piece of advice, verify your ribbon cable is inserted properly and fully seated. There’s been quite a few issues with the ribbon cables not being fully seated and causing this exact type of issue.

Yes @JustinBusby everyone is very helpful.

To make the spindle automatic, you have to run two wires from the power supply, SPINDLE PWM and GRND to a relay. That part is not in the instructions. I found it elsewhere. My question was about the logic switch as described in the instructions. I asked a question and many of the responses were about totally unrelated information, even after I found the answer and reported it back.

For the record, I disassembled the entire controller looking for this logic switch. Everything else works perfectly on the controller, the e-stop, all three axis controls, everything is good. I made some carves yesterday after I reassembled the controller and again everything worked perfectly except the automatic spindle control.

Thanks again,
Gary

Would you like to get automatic spindle control working?

Yes of course, Inventables assisted me in trouble shooting and we have a new power board on the way. We tried sending the commands directly to the controller to no avail.

“G”

What software are you using? Easel?

Can you post your $$ output from grbl here?

I would not know how to go about post the $$ output. Inventables looked at my code and didn’t see any problems.

“G”

Ok. The problem that I’m looking for is in the settings that tell grbl how to process your code.

Looking at your code would not be relevant for that problem.

My guess is that unless your power board does not have the connectors fully seated, then a new power board probably will not solve your problem.

One thing you can test while you wait is to make sure that the IoT relay is working. You can use a 9 volt battery hooked up as if it were the X-controller to see if the IoT realy will turn your router on/off. Make sure to use the correct battery polarity if you use this method to test your IoT relay.

1 Like

I echo your sentiment Angus.
Although I found great humor in your comment, I also recognize that alot of effort is put forth by many individuals for the benefit of us, the buyers and owners of Xcarve machines. Thier combined labors benefit us all.
Besides, Santa’s elves are some hard working sunofa…:wink:

guns.

2 Likes

Everyone,

Inventables promptly sent me a power supply board, I installed it and it works perfectly.

Automatic spindle start and stop.

Thanks Inventables, and Thanks to everyone for your input.

“G”

1 Like