Which GCode Sender?

What’s the preferred GCode sender to use with the X-Carve?
I’m currently using grbControl (Candle) and it’s OK but I’m having a problem where it just stops part way through a job - the USB port seems to hang. It’s likely to be the PC I reckon but I would like to try another gCode sender to make sure before I format and rebuild the PC (not a job I relish).

Have you tried using Easel? I’ve found the g-code import works pretty well so far.

1 Like

Have you disabled the USB Power Management?

1 Like

List of free/opensource options here: http://www.shapeoko.com/wiki/index.php/Communication_/_Control

agree w/ @picengravertoo that you should check your USB settings — grblcontrol is noted as working well on long files.

I use Easel when I need easy and fast without exporting g-code, great program all around. I use UGS when I need reliable and for large files (larger then 5 meg) for laser engraving etc. and then I have also Bcnc with great success. I have seen several program for sending g-gode and they all have there weak points and they all have things that they excel at. I first run the X-Carve on my girlfriends Windows machine but I eventually gave that back and now use a rasp Pi 3 tried all kinds of programs before I found the combo that worked best for me.

I’ve done some more tests and tried the same job running from my PC and then from a laptop and both failed part way through the carve. The job just stops dead and in most cases locks the USB/COM3 port so that I have to reboot the PC, switch everything off and start again. It’s just done it again and after I restarted everything and tried to use the Home button it said the functionality wasn’t enabled - well it was enabled 10 minutes ago. I’ve looked at $$ and sure enough, the homing cycle was disabled. Also the calibration setting I put in yesterday has also been set back to default.
I really don’t know what’s going on here. And the weird thing is that if I cut the same job above the workface in air all is fine and it completes the job perfectly every time.

Problems when the router is on, and not when it’s off indicates EMI from the router — suggest looking into grounding it, taking care to route the power cord so that it doesn’t interfere with the control and switch wiring, &c.

When I test it I always have the router on even when I’m cutting in air

When the router is experiencing a load it draws more current. If your noise issue is marginal, then the increase in current during carving could push the system over the top, noise wise.

You can try to reorient your router wiring and your USB cable to see if you can reduce the noise interference.

If your router has a lot of hours on it, you may need to replace the brushes as worn brushes tend to create more electrical noise than ones that are fresh.

You could try a USB cable with ferrite beads on each end of the cable.

Inexpensive USB cables tend to have more problems than ones that are built a little better.

Some people report improvement when using a powered USB hub.

1 Like

Curious, I just added that. :smile:

It wasn’t there I did an edit. We cross posted.

It’s a brushless motor.
This is what I’ve tried so far.

  • Installed ceramic capacitors on the limit switches at the gshield end
  • Replaced the VFD which drives the spindle
  • Replaced the Arduino
  • Rewired the spindle
  • Replaced the USB cable and fitted it with Ferrite rings at each end
  • Tested on a new PC
  • Disconnected the limit switches and disabled homing
  • Physically moved the electronics away from the VFD
  • Grounded the spindle to the VFD
  • Adjusted down the power to the stepper motors

Things I have left to try:

  • An even more expensive USB cable that’s braided and has ferrite beads
  • Replace the gshield

I think after that if it still doesn’t work it’s all going in the bin :frowning:

Here are some other things to try.

If you have the A/C power cords plugged into the same A/C circuit, try moving the computer/X-carve to an outlet that is on a different circuit breaker from the VFD and spindle.

Try using an Uninterruptable Power Supply for the computer and X-carve. They condition the mains as well as providing battery backup to the mains power.

1 Like

Nothing fluorescent. All mains voltage LEDs
Since I last posted I have disconnected the limit switches completely - the last time I left the black wire connected (stupid thing to do).
I’m now running a test job and so far, after 45 mins it’s not frozen. No guarantees yet because it’s played the “I’m all fixed now trick” on me before.

1 Like

Isolated the problem to the limit switches. When they’re disconnected from the gShield all is good. When connected it freezes at random. I’ve installed a new gshield and replaced the limit switch wiring with shielded 2-core. Ran the test again and it froze. I’ve now added the capacitors and re-running the test job. Looking promising now.
There must be some EMI generated when the spindle is under load and cutting wood but I’m not sure how that can be because it’s a 3-phase brushless motor and my limited knowledge says that it can’t generate noise because there are no brushes - obviously wrong.

1 Like


If you use homing and soft limits, the homing switches will only be active during the homing cycle.

With soft limits on, the switches are ignored after the homing cycle completes (unless you have hard limits enabled).

There must be some EMI generated when the spindle is under load and cutting wood but I’m not sure how that can be because it’s a 3-phase brushless motor and my limited knowledge says that it can’t generate noise because there are no brushes - obviously wrong.

You can read about noise issues here:


1 Like

OK, all sorted now.
The problem was solved by adding capacitors to the limit switch connections at the gShield end and replacing the standard twisted pair with braided twisted pair for the limit switch lines.
Thanks all for your suggestions and support. Appreciated.

A sad day. After a couple of weeks of trouble free carving it’s now back to its old tricks and freezing part way through a carve. I’ve changed nothing.
I think I established last time that it was the pesky limit switches that were the cause and shielding the wires and putting capacitors on the gshield cured it for a while but not now. X-Carve now unusable again as it can’t be trusted.
Does anyone know if the new X-Controller is any good and more resistant to this type of problem?

First, I highly recommend chilippepr. It works flawlessly (for me anyway). I was experiencing problems with randomly losing connection to my controller but I fixed it by replacing the USB cable that came with my X-Carve with one that has a ferrite core at each end. I haven’t had it fail one time since. BTW, one of the symptoms was that if I just ran a saw or drill press in my shop, it would lose connection. Anyway, I bought this cable: https://www.amazon.com/gp/product/B008VOPCGY.

1 Like