Why is my PWM signal always running on 4.3v?

Hey there! I recently installed a Opt Lasers to my x carve and the first time running it worked fantastic. However, when I unplugged everything and plugged it back in, my laser will not turn off. If I don’t turn on the x-controller and only turn on its power supply, the fan will turn on. But as soon as I turn on my x-controller, the laser beam starts burning. I checked my terminals with a multimeter and my PWM signal is always running on 4.3v - 4.4v. Does anybody know why and how can I fix it? I appreciate all the help!

have you tried to send the command to turn the laser off?


Yes, but no luck. I dont understand. As soon as the x-controller turns on, it automatically send the pwm signal to 4.4v. Here is the g-code the console starts-up with:

**** Connected to COM3 @ 115200 baud ****
Grbl 1.1g [’$’ for help]

$0 = 10 (Step pulse time, microseconds)
$1 = 255 (Step idle delay, milliseconds)
$2 = 0 (Step pulse invert, mask)
$3 = 3 (Step direction invert, mask)
$4 = 0 (Invert step enable pin, boolean)
$5 = 0 (Invert limit pins, boolean)
$6 = 0 (Invert probe pin, boolean)
$10 = 1 (Status report options, mask)
$11 = 0.020 (Junction deviation, millimeters)
$12 = 0.002 (Arc tolerance, millimeters)
$13 = 0 (Report in inches, boolean)
$20 = 0 (Soft limits enable, boolean)
$21 = 0 (Hard limits enable, boolean)
$22 = 0 (Homing cycle enable, boolean)
$23 = 3 (Homing direction invert, mask)
$24 = 25.000 (Homing locate feed rate, mm/min)
$25 = 750.000 (Homing search seek rate, mm/min)
$26 = 250 (Homing switch debounce delay, milliseconds)
$27 = 1.000 (Homing switch pull-off distance, millimeters)
$30 = 12000 (Maximum spindle speed, RPM)
$31 = 0 (Minimum spindle speed, RPM)
$32 = 0 (Laser-mode enable, boolean)
$100 = 40.000 (X-axis travel resolution, step/mm)
$101 = 40.000 (Y-axis travel resolution, step/mm)
$102 = 188.947 (Z-axis travel resolution, step/mm)
$110 = 8000.000 (X-axis maximum rate, mm/min)
$111 = 8000.000 (Y-axis maximum rate, mm/min)
$112 = 500.000 (Z-axis maximum rate, mm/min)
$120 = 500.000 (X-axis acceleration, mm/sec^2)
$121 = 500.000 (Y-axis acceleration, mm/sec^2)
$122 = 50.000 (Z-axis acceleration, mm/sec^2)
$130 = 740.000 (X-axis maximum travel, millimeters)
$131 = 790.000 (Y-axis maximum travel, millimeters)
$132 = 100.000 (Z-axis maximum travel, millimeters)

[GC:G0 G54 G17 G21 G90 G94 M5 M9 T0 F0 S0]

There is no: turn laser on, command is there?

Yes. Read here.
But that’s not your problem. Your PWM should measure 0v in the M5 state (which you’re in on startup). Check your wiring.

It ignores the M05 commands and the laser company said the wiring is correct. I only have four wires. 2 go to positive and negative from the power supply. The other 2 go to gnd and pwm. The only two wires I could change are the logic wires that connect to the x-controller, which i already swaped but the result was just a non-firing laser at all. Yes, I should not have voltage on my PWM terminal if I’m not sending the command but it still throwing that voltage from startup. In the g-code that is being generated from startup I dont see anything that implies a voltage to those terminals. So what can it possible be?

It’s not ignoring them. Your signal should be 0V.
Disconnect the laser…what’s your PWM voltage? (Leave it disconnected until this is sorted, by the way)

Its disconnected. I brought the x-controller home with me and doing all type of tests with the multimeter and UGS.

The voltage is 4.4v in Spindle PWM and 8.8v in Spindle (0-10V)

What do you get on your Coolant pin?

0.0v. It seems to be only the PWM and (0-10v) terminals.

How about your limit switch pins?

x limit 4.8v
y limit 1.9v
z limit 4.7v
probe 4.9v

That’s odd too.

Looking at the schematic, I see two places that might be easy to short PWM to 5V.
One would be on the connector that goes from the main board to the “Rear Connectors”. The other would be on the 6pin ICSP header where the MOSI pin, shared with the PWM, is right next to 5V.
I don’t know what could be going wrong if there are components NOT on that schematic (I’m guessing there are).
Visually check for shorts. Maybe disconnect everything, use some canned air, and then reconnect.

Beyond that…you may have an issue with the board or the MCU.
I’m off to bed…good luck!

1 Like

So, if I am having a voltage higher than 5V on any terminal and there is only two places where it would be easy to short to 5V but only one has a 12V power input, then it would be the opamp that’s damaged inside, correct? Everything looks good on the outside, by the way. Thank you so much for your input!

I don’t think so. It’s doing it’s job of doubling your output voltage. I’m leaning towards the MCU.

How could I test that?

That’s a tough one. Tracking a short isn’t easy.

Before you do that, why don’t you reflash GRBL…see if that helps?

I already reflashed, updated, and reseted it :frowning:

What do you get on the PWM when you send an M3 S12000?

Can you measure voltage at the ICSP header?

Pin 4 there is the PWM signal.

I’m getting 4.4V on that pin regardless of the command I send