Inventables Community Forum

Why would a cut go off of it's toolpath?

It didn’t follow the simulation. Stopped 25% through cut, didn’t raise the bit, and started cutting back to the front of the machine in a straight line along Y.

What would be potential causes?

  1. Poor network connection?
  2. Power spike?
  3. Bit or router slipping? I checked these - both firm.
  4. Design problem? I ran the simulation and it did not follow the erroneous path
  5. Mechanical issue with CNC. Its a new Sainsmart 4030 – the bit didn’t raise, and went straight back on Y, when it should have been going forward in a curve, so all 3 axis would have had to fail, seems unlikely.

The carve did stop on two prior runs, with the spindle still going. I saw a Youtube video that said this is typically caused by a power spike. This is why I think 1 and/or 2 are likely, but I’m a newbie. I am running everything through an IOT Relay after my surge protector, I’m going to move the controller and my vacuum straight to the surge protector, and I’ve already moved a mesh wifi end point into the garage.

If the machine is just stopping and not going forward with the carve, this is normally an indication of EMI issues. There are plenty of threads discussing this, but you will want to separate the USB cable from any power cables for starters. Grounding the controller side Shield/Drain (to GND on the controller) on each of the stepper cables is also another option to consider.

With respect to the machine going off the path, I suspect the machine simply lost steps due to the feed/speed being too high with the 1/4" bit. What feeds/speeds are you using?

{:0)

Brandon Parker

#1 The network connection would not have anything to do with this issue. the gcode is stored locally on the PC prior to starting a carve, you can actually sign into easel, then turn off the network, complete the design and then send the gcode all without a network connection. (save for design library, font directory and the tools)

#2 Possible, but is your cnc setup to auto home to the front left on power on? this could explain the return to 0 path :man_shrugging: Other than the return to 0 then what you’ve explained sounds exactly like a static discharge taking out the power momentarily.

#3 seems fine
#4 should be okay, however I see your using Pine in that preview, but your cutting Poplar. What are the cut settings?
#5 since the prior carve (deeper line cuts) went through the path I doubt its a cnc mechanical issue

1 Like

I don’t know if my machine is set to auto home, but definitely seems like that was where it was headed, albeit not raised.

You are correct, I was cutting poplar but set to pine. I used the default Easel settings, which I think was 40 IPM and seemed fine, since there was no poplar option in Easel. Would love to know a recommended wood option for poplar, I thought pine was close enough based on my Janka scale Google search.

To be clear, I don’t export my gcode, rather I just run Easel. But maybe you’re just saying this is the way Easel works. I thought the network might matter.

Btw I did also have a hose and dust boot attached, but it seemed to be running fine and had decent slack.

Feeds and speeds:
Feed Rate = 40 IPM
Plunge Rate = 9 IPM
Depth Per Pass = 0.0625

Bit = Freud 1/4", Upcut, 2 flute – brand new
Wood = Poplar, but selected Pine in Easel

You can see a downcut outline went well prior (without the dust boot).

Yes, the wood hardness(janka) is similar, but poplars cellulose structure (longer and more stringy) makes it grab onto the bit more than pine and this can add resistance to the motors similar to how a harder wood would act.

That said, when I cut poplar I prefer to carve using the raster direction in the direction of the grain, this does cause long stringy fibers as offcuts but it cuts a lot smother than going across the grain at all.
Also doing it with a raster means less slotting and slotting puts more resistance on the steppers and the spindle…

Now I do think the issue is power related though and has nothing to do with the cut specs anyway, but since I saw pine and poplar I wanted to address it to hopefully get you on a better track for cutting it :grinning:
.
.

I guess you could test the auto homing by powering it on and seeing if it homes automatically.

You could do a similar power spike test by running a carve in air above the workpiece and momentarily cutting power off and turning it back on (you could repeat this test with unplugging and replacing the usb)

All to see if any or all of these result in the cnc returning to home.
If it is returning to home during a power drop, you’ve identified the issue then it comes time to identify the root cause, but tbh its usually the vaccume.

Much more success this week. I didn’t do the same carve, but ran several test carves with no issue. Here’s everything I changed:

  1. Disconnect the offline controller - Sainsmart says you should not have both an offline controller and laptop connected
  2. Disable power save features on the laptop
  3. Change surge protector - 600 joules protection to 3,500
  4. Remove the Controller from the IOT Relay
  5. Only have the router in the IOT Relay
  6. Plug everything else directly into the surge protector - vacuum, laptop, controller
  7. Isolate the USB cord from other electronics
  8. Add a wifi access point in the garage
  9. Ensure dust hose has slack
  10. Change wood - used pine instead of poplar
1 Like

Since your in the mood to cover all bases regarding the issue.
It’s a good practice to also disable USB selective suspend, this is a new windows 10, April-ish of 2021 addition that by default gives windows the choice in whether the USB stays active of turns off, and this is regardless of the main Power/Sleep settings!

Thanks Seth. I think this will be helpful for Windows users. I use a Mac. I just went into the power settings and turned off everything that seemed to make sense.

Thanks for information, Really helpful and thankful for me.

1 Like