Win 10 and UGCS

Picked up a new Windows 10 tablet, downloaded Easel - which works great, but am trying to use UGCS (to duplicate the process I used with my Macbook pro) and can’t get it to work. Either it says Comm port busy or it hangs while Grbl is booting. Disabled the Arduino driver and now UGCS at least sees the machine, but like I mentioned, Grbl never boots.


Make sure Easel does not run in same time.
Check to see if COM port is assigned as Device Manager assignment.
Also make sure Baud Rate is 115200 as shown on the picture.

1 Like

Got it figured out.
In Windows ( different from the Mac) you have to select a different start file for the UGS to load everything ( I think…)
Once I selected the Start file, and selected the correct com port in UGS, it worked.
Finally!! But at least it worked.
Now I can put my expensive laptop back in the house and use my $60 tablet to push G code.

1 Like

I’m using most expensive desktop for carving. Nothing more expensive than wasted material and time. Frustration is the extra. You need strong USB port and solid system for long jobs. You’ll find out.

True, but the job I’m running now, pretty much as a dedicated machine, is a 45 second tool path X 1,000 parts per month. I’m hoping this tablet can keep up. We’ll see.

Another thing that might make a big difference is that I’m not using easel, or anything like that, on this tablet. Strictly using it to send text ( G code).

1 Like