Wobbles after a corner... pictures attached

Okay x-carve hive, I need some help here…

I am carving a logo based on a project I’m working on, but it doesn’t seem to want to do it correctly. The logo is pretty simple, but no matter what I can think of, I seem unable to get it to work… I’m using easel. The really frustrating part is that the very first time I did a test carve of this, it came out perfect. But never again. I have shared it below for anyone bored enough to try to help me…

Here’s what I have already checked:

Belts: All tight, use cable ties on the ends and they are thumb tight. Maybe too tight?
Wheels: All in contact, all tight and barely move when moved by thumb and finger. However, they do (when power off) move then sort of pulse on X when I move the gantry. Ie… smooth motion then sort of sticks and requires 20% more power to move it… Looked at the wheels and they are all smooth and undented, the rail is clean.
X Y Z: Adjusted stepper motors as everyone describes to be in between the max/min settings.

Pictures below…

Many thanks in advance for any insights…

Have you ever checked the pot voltage settings for each axis? My machine used to lose steps sometimes which looked very similar.

Hey Robert, checking them now…

Belts are all very tight, all Vwheels are solid as well.

Thanks David, I will check and let you know.

BTW, I did adjust them before marking the lowest and highest settings, and setting the dial to be between the two marks. Is there something else I’m not doing there that I should?

Look at my post asking for an aluminum guru. My problem looks exactly the same. What cured it was a combination of things, but I believe the most important fix of all my issues was that my part was not held down extremely tight wich caused chatter and made my bit walk off the tool path. My part was so big (12x30) that outer clamps alone weren’t even close to sufficient. What I did was run the drill bit all over the part and dropped the z axis to check where it was high and then dropped a screw through it where scrap would be cut out later. Not until after the part had 20 screws through it (and table/machine were made straight and even) did I finally get a clean cut part.

Maybe I missed your feeds and speeds, but make sure you’re not going too fast or too deep. That’ll chatter and walk a bit too

Hey Phil, I will try that tomorrow and report back. Is this a hunch or something you have found in the past?


So… re did the voltages on the x,y,z pots… also checked all belts, V wheels and screws. I even swore at it under my breath. But the result after a quick test was the same…

The piece is very securely mounted (clamps and glue gun underneath.)

(edit) Something I noticed is that the error seems to be the same shape each time… that seems to point more to a software thing than a mechanical surely? If purely mechanical, you would expect it would be different each time right?

Hey AustinTX,

Thanks for the suggestions, I will look in to them. I have glued down the MDF and it doesn’t move at all… in fact, I have to work hard to take it off later!

Re speeds and feed, I am just using the recommended settings in easel.


Nope, that’s all I ever did.
The other one that caught me out was the grub screws that hold the toothed pulleys onto the stepper motor shafts would slip under force - they seem tight, but they’re so small it’s hard to get enough clamping force. I replaced them with longer machine screws & the next time I’m in there, I’m going to file a flat onto the stepper motor shaft to make it a little harder for it to slip.

On the new (used) 1000 mm XCarve I just got, the thing that got me was that there were no flats on the motor shafts. I had to file each one by hand to make sure I had a good surface for the bolts to lock onto.

I created the G-code from your example and visualized it in UGS 1.0.8, the wobble does not show on the toolpath.

There seems no problem in the g-code easel created. Possibly a bug in GRBL so maybe you can go down a version or two and see if it still reproduces. When making parts on GRBL v0.8 with tabs I do not experience these kind of problems.

The behaviour looks like play, loose belt/ pulley or even one of the Y motors not joining the party. If one of the Y motors does not power up properly you get a big backlash when changing direction.

Here is a little test, I made a corner in LibreCAD and used EstlCAM for making the toolpath. If you send this to your machine with UGS there should be no reverse action around the tabs. I chose 6.5mm for material thickness. If it runs ok there is a software problem, if not a mechanical issue.
Corner rounded.nc (2.3 KB)

thanks, I will test and let you know.

How much stick out do you have on the tool? Are you using the largest diameter tool you have for the profile cut?

With the power turned off, if you grab the tip of the tool and try to move it left/right, backward/forward, up/down do you feel any play?

Looks mechanical to me. From your first picture, it looks like it is happening on every cut. Would be interested to see a picture of your setup showing the material thickness and bit type/length.

Do you have a way to measure your belt tension? It’s possible to have it too tight, which can cause some lost steps.

Easel default settings may not be the best ones for your bit. I’ve found that with a 2 straight flute flat end bit I can go shallow and fast, while a 2 flute upcut ball end can go deep and slow. Cut your cut depth and speed in half and let it make a couple passes. If that looks, good, then repeat the test with deeper cut depths and higher speeds until you notice problems.

Thanks Allen for the questions… Using a 1/8th 3F, no play in the bit at all…

1 Like

Cheers Robert for the ideas. I’m using a 1/8th 3F bit. Belt tension is “guitar string” tight. I can get a thumb under the belts on X and Y just about, but they don’t feel over or under tight. I have had reliable cuts, even on this design before… but suddenly it won’t cut this section of the carve.

I will try a different bit and also settings in easel and see how that affects. I’m pretty new to all this so the set backs are merely a challenge!

Sometimes when the tool changes direction if there is any play in the machine, the tool will deviate from the expected path (like what you are seeing) as the tool transitions from conventional to climb cutting.

If you are able to create a toolpath that uses climb cutting instead of conventional, that would be a good test to see if something is loose or not.

Changing the direction you cut should move where the deviations occur (if something is loose)

Hey Robert, I have used a glue gun to secure the stock to the table. It is rigid as hell and doesn’t move even a mm when I yank on it. I’ve used this method before and for other cuts (including this one the first time I carved it) it worked out fine. Puzzling.

So… have tried the suggestions above… nothing is helping.

Material is solidly on the board, no play.
Bit is solid in the router, no play at all.
Belts are tight, but not over tight.
Wires are all connected solidly, not lose.
Pots are all trimmed and set to the right levels.

I just did a test where I ran the carve at half normal speed 20in/min with 0.025 DPP and it did the exact same error but this time very very slowly…

This has got me very confused.