Won't work on my mac - please help

After 24 hours if not more of assembly, I’m ready to carve and it tells me I need to download the app. I do. It installs properly. Nothing happens. It keeps telling me I need to download the app. I’m running 10.6.8 and going through firefox.

What stage have you reached in the XCarve assembly instructions?
What App are you trying to download?

thanks for responding!

I’m fully assembled. I was trying to download the Easel driver for my mac. It would download and then nothing would happen, I’m running OS 10.6.8. I switched to my wife’s computer and it downloaded, she’s on OS 10.10.5. However, a new problem has occurred. When I try and set up the machine it tells me “plug in your usb cable,” it is, the machine is on… and nothing is happening.

When I manually move the x,y and z axis the lights and fan turn on so I feel like all the wiring is correct. I’ve changed USB wires, I’ve shut down etc. etc.

Everyone on a mac seems not to be having issues except me.

There are others on this forum with more experience than me but I think the correct order of things is to attach the USB and then switch on the XCarve.
It may be worth searching the forum for previous posts where users have had a similar problem, I’m sure its been covered before

I use a Mac. THe issue that I have seen is a little odd. I can not leave the machine USB plugged into my Mac laptop upon boot up. When it is plugged in the Mac does not want to load, I just get a black blank screen. I have to unplug the USB. Boot up the computer. Plugin the USB, power up the machine and it works.

I do not know why it does this, just that it does and how to get around it. My mac is running the most current edition. I have not tried it using an older machine with the older software.

Good luck and sorry that I can’t give any more assistance.

The mac sees the Arduino as a bootable device and tries to load it as an OS. Obviously it can’t, so it just sits there waiting for instructions from it that will never come. Mine does the same thing.

Are you running Adblock on Firefox? I had the same issue in Firefox and it was because my adblock settings weren’t allowing Easel to see the Easel Local app was running.

Also, try using Chrome just to see if you’re still having issues.

Help is here.
I am both a Mac Genius and an XC owner/operator.
Easel will run fine in 10.6.8 but it will not send G code. UGS is needed for that.

This is because 10.6.8 does not have the tools to interface from Easel and XC.
Once the upgrade to 10.7 that changes and all is good but not all Macs can do this.
I used a MacBook Pro with 10.6.8 on it and had to also use UGS to send, a hassle but it worked.
Also Safari does not like to download exported nc files, it only opens a new tab/window. Use Firefox or Chrome for design work in Easel then export as G code.
The you can use UGS to open and send to the XC.
Is that enough or is more detail helpful?

1 Like

Thanks guys for getting back to me. I think I’m gonna call inventables this is all a bit confusing for simple woodworker. Don’t understand what the difference is between easel and arduino and grbl etc. Inventables is doing a bad job of explaining and helping those with little programming knowledge. This is a frustrating process… seems like everyone has a different solution to get their xcarve up and running.

thanks again!