Writing configuration - hung up

I have not worked on the Xcarve for a while. On resuming, there were a number of updates (both Win10 and Easel drivers). Now, I cannot run my machine anymore.

The “carve” button is turning green when I plug in the USB, but I cannot carve or navigate with keys or mouse.

I run Win10, tried two laptops, turned off the USB power saving, installed the latest Easel driver (v0.3.20) and run Chrome browser.

The following screen is getting shown:

What can I do to get going again?

Thanks, Marlin

It looks like your settings are no longer in memory.
Try to go thru the setup again.
If you make steps/mm calibration adjustments you should save the info for later if this happens again.
You can copy your grbl settings as a text file for later reference.

I am in setup when this screen appears and gets hung up. How do I proceed?

I am having the same issue on a new build. Downloaded the driver today, plugged in and turned on x-controller and it is just sitting at that screen…

I got it fixed after talking to customer support.

I had cleaned the controller and one of the buttons (pause, reset) was stuck. So, it did not allow to accept commands.