Wrong depth on z-axis with grbl software

hello, i’m using cambam software to generate gcode, and grbl panel to upload it to my x-carve with acme rod.

but i have still a problem of depth… when grbl see 3mm of depth, i have 3.9mm in reality…

can i solve that by changing a parameter in grbl on the x-carve ?

it’s the $102 parameter right ? i just need to put “$102=190” to change it ? will it be saved after a shutdown ?

Each machine is a little different and settings are unique to each as well.

you will need to find out what your current setting is, how far off it is, do the math and THEN enter the new settings into grbl.

This will help in getting things straightened out.

ok i understand, i’ll search how to display my actualsetting without easel