Inventables Community Forum

Wrong depth using Z-probe

I have been using the Z-probe for a long time without problems. Today, I was running a project that I have ran about 15 times and the first cut went down approximately 1.5 mm when the depth setting is at 0.2mm. I restarted, checking to make sure the disk stayed flat on the corner of the wood, same problem. If I set it manually, it runs fine.

I’m not sure if this helps but I had the same issue a few months back, turns out I was forgetting to setup my home in mach3, probably not the issue your having but worth a mention

What software are you using to create toolpaths?
If is is Vectric do you have Z set for the surface of the wasteboard?

I’m using Easel. I found the problem. No matter what I set the depth at, Easel sets the automatic carve setting depth per pass to 1.3mm. I’ve never had this problem before. The setting shouldn’t be more than the cut depth of the project. Is there any way to change it? I’d hate to have to go through all my projects and set the depth manually. 1.3mm is way to deep for a standard cut depth.

The depth per pass should not over-ride the depth setting.
You can choose manual setting and make it what you want. However I think you may have another issue.

1 Like

Thought I had it solved, but I was wrong. Every time I start the X-carve, the first two carves are at the wrong depth. All subsequent carves are correct. I’m at a loss.

I am also having the same issue on my Genmitsu CNC Router 3018-PROVer. I have the depth per pass set to .3mm and the total carve depth set to .6mm but when I carve the depth keeps carving at 1.3mm no matter what I do.

How can you carve shallower depths???

@BrianBone Brian were you able to get it to work?

@JonathanFrench Your grbl settings are incorrect. Pretty common for the 3018 users here.

@NeilFerreri1,

That is my router. What settings should they be? I don’t see the grbl settings on the link you sent.

Sorry if they are there and I don’t see them.

Thanks,
Jonathan

Read the posts leading to that one.

Hey @NeilFerreri1,

I read through most of the post but only saw settings for the laser not for regular milling. Just curious you said my settings were wrong, which settings do you think are wrong?

Thanks,
Jonathan

Hi @JonathanFrench,
The thread I linked to was entirely about a guy with a 3018 that was cutting too deep.
Anyway, what’s your $102 setting?

Hi

Go to Grblcontrol app of 3018 and in the down right corner in the console, type this comand “$$”. This will show you a bunch of settings, scrool up until u see numbers $100, $101, $102. Al 3 should have the same numbers but because depth is wrong $102 number is deferent.
To fix it just type in the console $102= and then type the same number as in 101.
You can also whatch https://www.youtube.com/watch?v=HDZViQ1na8s&ab_channel=NAW_Garage