Wrong size

The sizes of the shapes that it carves are wrong. When I try to do a 7-inch shape it makes a 2.5-inch shape and when I tried to make a 2-inch square it made a 5/8 inch square

Welcome to the forums. Have you calibrated your machine so if you tell it to go 2" it does go 2"?

How do I do that? I am pretty new to CNC machining.

Search the forum here for cailbrating your machine and you should find plenty of results. Up in the top right corner where the magnifing glass is click on that and type in what you are looking for. You can check to see if it is off by laying a ruler down under the bit and tell it to move 5" and see how far it moves.

How do I change it to make it to go further?

It is all in accurate measuring and changing your appropriate $ settings. I have how to do it written down in my shop but can not explain it to you off the top of my head. Some one will chime in. Run a search for calibrating your machine and see what you come up with.

So I figured out how I am supposed to do it but I cannot figure out how to tell the machine to go a certain length down the X axis.

Just open easel and some file you have. Go to the top and hit the carve button. That should open up and you can move the machine around. Type in 5" and use your arrow keys to move the machine in the direction you want it to go.

1 Like

I figured it out but when I did it the stepper motor moved much faster.

Did you change any of your settings?

Yes, I changed the steps/mm

Not sure why that would spped it up.

Is there a setting where I can slow it down?

You should have only changed the 101 and 100 settings. Did you make a copy of what your setting were before?

I only did the 100 setting. I have not done the 101 yet. Would changing the feed rate change the speed? It was 700 before I changed it.

Sould’nt have been 700 is pretty high. Are you working in mm or inches?

Inches, when I changed it to 39 it only went .25 when it was supposed to go 5 inches

Can you copy and paste your setting here.

file>share>share with link>save>paste link

@NickEPravlik - first, welcome to the forums. You will find a wealth of information here and some very helpful people. I recommend you take a deep breath, read up on how to calibrate the machine and watch some of the instructional videos. Then pause - digest all the information. Read/watch them again. Then pause, create a plan, then methodically adjust X, Y, and Z parameters for optimal results.

If your X-carve is not moving the distances it is instructed to move, there are usually very few causes:
1 - it is not calibrated properly
2 - there is something mechanical impeding motion
3 - there is something electrical affect motion

99.99% of the time, it is #1. Start there. The machine is fairly well calibrated out of the box and it shouldn’t be off by 250% IMHO.

CNC has a steep learning curve - it’s not “push a button and cut” like some folks want to make it out to be. Maybe someday some one will have a fully integrated tool chain that is super easy to use and a fully build machine that requires no tweaking. That’s not where the community is and that is not the X-Carve (sorry @inventables).

Here are some links to get you started:

http://x-carve-instructions.inventables.com/1000mm/step11/





https://wiki.shapeoko.com/index.php/Grbl_Settings

Hope all this helps!

-Tom