X and Y Axis Calibration Issue


I have noticed some dimensional accuracy problems with my X-Carve 1000mm x 1000mm.

I made a test piece in easel. The piece should be a 70mm x 70mm square, but it came out 67.2mm x 68.5mm. The piece also has a pocket that should be 50mm x 50mm x 6.4mm deep. It turned out 46.7mm x 47.9mm x 6.4mm. I am cutting with a 1/8" upcut bit, 2500 mm/min and the material is HDPE.

I have tried calibrating X and Y and they both moved exactly 100mm when I sent the command to move 100mm. I have also restored the firmware and I have checked all of screws for tightness. The waste table is also pretty flat relative to the spindle (only about 0.2mm variation from high point to low point).

Anybody have any suggestions?



Hi Jon,

I don’t have my X-Carve yet, still have about 5-7 weeks before it arrives, but in reading thru this forum I have a few things for you to check. And if I omit something or get it wrong, there are others here who have an amazing amount of knowledge, troubleshooting experience and a good willingness to help.

First of all, 2500mm/min seems way too fast to be cutting with the X-Carve, most people here cut much slower, it all depends on the bit, the material, depth of cut and modifications that have been made to an individual X-Carve. (If it’s been beefed up, it can cut faster).

Did you accurately measure the cutting diameter of your bit? Not the shank, but the fluted end. The easiest way to measure that would be to cut a straight line with the bit in some test material and measure the width. Measure as accurately as you can, most people use a digital calipers.

With your cut of the square, are you cutting on the line, to the inside, or to the outside? It makes a difference as to where the cutter goes to how much material is left behind.

Did you calibrate the stepper motors? They can act differently under load if they don’t have sufficient voltage to them.

Is everything tensioned properly? Belts tight? V-Wheels good, etc.?

Those are most of the common reasons for dimensions being off. I’m sure that others can offer you further suggestions.


If 2500mm/min is too fast, is there a part of the documentation that specifies what travel speeds are too high? My cut quality is really good, so I would rather not adjust travel speed unless I had to.

When cutting the test piece, I used Easel so unless I am missing something, there is no way to input a measured bit size. The only choices are the bits that Inventables. I clicked on the picture that looked like the bit that I had installed.

For the outside cut, I chose “Outside”. For the pocket, I chose “fill”.

How do you calibrate the stepper motors when they are under load?

Everything might be tensioned properly. The belting sounds like a string on a bass guitar (don’t know what the “bass string on a guitar is”). Its kind of easy to push the gantry around, but I have no idea what it should feel like. The documentation on that was sparse so a lot of it was guessing.

I have been experiencing the same issue with my 1000mm x 1000mm machine. I have tried cutting some test squares as well, and they seem to always come out under size, being inside, or outside cut.I even went as far as cutting a test groove, measuring the groove left, and setting the bit size to the exact measurements (used the “other bit” option to do this) and the same result. I even tried using a Raspberry Pi 3 B+ with “bCNC” program to see if it was and issue with the Easel program, same result.
Is there a way to look at the GRBL setting of the X-Controller and be sure all is as it should be in there?
Thanks for any input.
P.S. this account is listed in my wife’s email instead of my own but that’s another story.