X Axis keeps shifting to the right...bit by bit during cutting

I’ve been using Easel to carve out my projects, recently this problem came up, I’ll list down the troubleshootings that I’ve done.

  1. Adjusting all carriages nuts and eccentric nuts, tightened till the wheels can only be turned by force.

  2. Soldered wires of X-axis nema23 and spindle to electrical rings before putting back into the terminal block (it did help a little, like 50% of the problem, some how)

  3. Adjusting the current on the gShield being sent to the motors.

What could be the reason that this is happening?

What spindle you have. 24V stock spindle or something else.

Something you might want to try - I see that you have correctly adjusted your V-wheels, but have you checked your belt tensions and the setscrews on the stepper motor pulleys to make sure they aren’t slipping?

@AlanDavis - Yes, I’m using the stock spindle, I figured probably it’s electrical current is messing with the X-axis somehow as I read in another thread, so I re-wired it, helped like i said 50%±, still doesn’t solve the full problem.

I purchased a Dewalt 611 + Mount, but that’ll take like a month to reach me in Singapore. So meanwhile I have to troubleshoot what I can as I have some orders to fulfil for my business.

@DanBrown - Yup, I’ve tightened the belts and setscrews, definitely not slipping, not sure if it’s too tight though.

Alan is probably onto something with the spindle, really. That stock spindle was VERY prone to noise problems and interfering with the steppers. If you run it without the spindle running, just, say dragging a pencil around a piece of paper on the waste board, it might be revealing.

Are the x/y/z axes square? Mine were off by quite a bit and fixing that made a huge difference.

You already know what is the problem. Looks like spindle interfering. Easy way to understand, you can turn the spindle on manually from toggle switch and watch green LEDs if any flick going on, and any stepper movements.
When my Spindle failed same way, 611 mount wasn’t available.
I used another 24V power supply just for the spindle, used stock power supply’s spindle output for relay to turn on and off. Also using second power supply’s voltage adjustment for RPM. It worked without problem for a month.

Have you checked to see if at least one of the setscrews on the motor pulley is on the flat part of the motor shaft?

Another temp solution is, if you have Dremmel sitting around, it is the same diameter with stock spindle.