X-axis motor jitter

I’m have problems with the x-axis motor jittering when it’s under load.
I’ve tried everything: adjusting the belt, checking the v-wheels, checking all the wire connections, swapping motors, adjusting the amperage, etc.
I’ve tried everything I can think of except for replacing the controller.
I’m not using the g-shield, I’m using a TB6600 and mach3 to run it.
Can anyone help me figure it out?

Have you tried switch the X and Y connections to the motors. If it follows the motor, the issue is the motor, if it stays with that controller, it’s that controller.

Yes I switched one of the y-axis motors with the x-axis motor and it still was the x-axis having the problem.

What sort of load are you talking about?

Like while it’s cutting wood. It doesn’t do it when I test it raised not cutting, even with the spindle running.

Have you tried halving the feed rate?

You have two motors on the Y axis, which stabilizes its motion more than would be with the X axis. Which NEMA stepper are you using, the 17 or the 23? What sort of cutting bit (diameter, # flutes), spindle RPM, and feed rate are you using? It sounds like you might just be moving too fast for the X axis stepper motor to keep up and it’s struggling.

Nema 23 stepper motors, 1/8" straight double flute, running the Dewalt 611 at 4 on the speed dial
I’ve tried running it at 50in/min and 20in/min, it didn’t seem to make a difference. I have also adjusted the acceleration but that did make a difference either.
It doesn’t do it on straight lines or smooth curves, only when the curves are made up of a bunch of tiny line segments.

What is your depth of cut?

1/16" per pass in soft pine which I’ve never had a problem with before.

You are correct, it should handle that. Not related, but for soft pine my Dewalt is set on 1 for the speed control.

Is the bit dull?

Doesn’t seem to be dull. If it was dull then it should also be doing it on straight lines and smooth curves, but it’s not. When the issue first happened I changed some things and then ran 8 tests, they ran fine and then on test 9 all went wrong again. I will try a 1/8 spiral and see if that makes a difference.

Can’t really think of anything else…check x-axis pulley set screws.

That’s one of the first things I checked along with the belt tension from reading other posts on the forum.

Well I think I got it figured out, it seems to be a mix of a cheap dull bit and the spindle motor running too fast hitting the bit up too much causing it to cut poorly and provide too much resistance/load for the x-axis motor.
Once I put a new bit in everything seemed to work good, even with birch plywood it seems to work.

Thanks everyone for your help, I really appreciated it.


That was literally my next guess when I saw that you had spindle at the 4 setting. Most people working with wood/plastic usually are good with 1 or 2 on there. When it’s too fast it dulls the bit because instead of taking a cut it just rubs and rubs. You might have been able to get away with just upping your feed, but I don’t think the X-Carve can really handle moving fast enough to keep up with the DNP611 on a setting as high as 4… There’s only one way to find out!

1 Like

Have you checked the thermal threshold of the IC? The tb6600 has a tendency to get hot and when it reaches its threshold it could cause such a problem.

Thanks for posting this and all of your troubleshooting steps. I see this was posted back in 2015, but helped me today in 2019. Was experiencing the same thing, performed all the steps mentioned, and then replaced the bit. Now things are fine. This was literally the last thing I would have thought of as you can’t really tell when a bit goes dull? Cheers.