X Axis motor not working correctly, need some help

I’ve been running a project all day long today and on my last run for the day the x-axis locked up and cut a nice deep line across the entire project. Not a big deal about the project but I’m only halfway on a tight deadline.

Here is what I have troubleshot so far:

  1. turned everything off, y1 and y2 move smoothly, Z moves smoothly, X is very hard to move and sounds bumpy.
  2. took X motor out and it still isn’t moving well if turned by hand
  3. Unplugged and it seems to move just fine
  4. Plugged back in and not moving well
  5. Plugged X motor into Y2 cable and it moves just fine
  6. Motor when plugged into X cable, even when the cable is disconnected from controller, still isn’t moving correctly.

My assumption is something with the controller or wiring?
Can anyone help me out!?

Darren D

No wires connected to anything, unplugged?
If so, trash that stepper, something isnt right.

it’s fine when it’s unplugged from everything, as soon as it is connected to the cable it stops. I tried switching motors and its the same thing. I think that my cable is bad… I tried switching out the connector and the same thing happened so i have to think its the cable

Even when power is OFF?
If so it sounds like you have a incorrect wiring or a short between your wires some place outside the stepper.



It ended up being a bad wire that inventables was able to send me a replacement very quickly! Really really great customer service!

1 Like