X-axis no longer homes

I have been using the X-Carve for about 2 months without issue. I use Easel and know almost nothing about g-code. I switched to a different computer to carve a small part and pulled up Easel. Whether I ask it to home under the “machine” tab, or after pressing “carve”, the machine only homes on the z- and y-axes. It never moves in the x-axis. I tried machine setup and have the same issue. I did a manual home and that worked, and was able to carve my part. I can also toggle the machine in any direction. The wiring looks intact, and I doubt it is a switch issue because the issue is that the machine never moves in the X-axis rather than ignoring the home limit. Any thoughts?

What do you mean by “manual home”? Did you issue a $H command to GRBL or did you move it to X/Y/Z zero and set position?

To me, either your X switch is broken and stuck closed or your X switch wire is shorted. It probably doesn’t move because it immediately senses the switch is closed.

Have you switched back to your other computer and tried again?

Follow the post linked by Phil to see potentially what the issue is.

If he has the X-controller he will also need this:

1 Like

This gentleman indicates he knows noting about gcode. How else could he tackle his problem within Easel?

I don’t see any reference to G-code in this thread apart from his saying that he doesn’t know it and you saying that he said he doesn’t know it.

1 Like

Thanks for the ideas, but several of you have already pointed out an issue that keeps me from understanding your advice - I do not know g-code. It would be nice to learn, but it is unlikely that I will be able to pick up advanced skills in the near future. My role in this is as an advisor to a high school robotics team - we have just branched out into CAM and most of my efforts are directed at teaching them the very basics of CAD with enough CAM to make simple parts (which is the extent of my knowledge at this point). I currently design in Autodesk Inventor, concert to SVG with Inkscape and import into Easel. Once I get the hang of feeds and speeds, I plan on converting to Fusion 360 and generating the g-code for Easel. That is my summer project. If someone has a recommnedation for how to learn g-code for a non-programmer, I would appreciate that.

In Easel, you can choose to home with the switches (and the z-probe) or manually. When I try to auto home, the x-adis does not move. There is no error message, but the homing cycle never ends. If the switch were closed, it should go to the next step with a home that is not at the true home. If I trip the switch manually, nothing happens either.

To clarify a question posed above. - When I do the manual homing, I toggle x, y, and z in Easel and “home” is actally the starting position of the carve

As for the g-code, since I am using Easel to create the code, I am not sure if it is created at the time I try to home. I do not know how Easel sends its commands. If someone familiar with Easel can tell me what to do to retrieve the code, I can try that. I will try the other computer as well and see if that makes a difference

The references above are intended to have you use grbl to debug your homing switches, which is the best way to do it since you actually see what grbl is seeing.

If that’s getting too deep for you then you can test the switches with a multi-meter right up to the gShield or X-controller to see if they are functioning properly and to debug them if they are not.

Do you know how to use a multi-meter?

1 Like

Here are the grbl settings:

$132=100.000 (z max travel, mm)
$131=540.000 (y max travel, mm)
$130=540.000 (x max travel, mm)
$122=50.000 (z accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$120=500.000 (x accel, mm/sec^2)
$112=500.000 (z max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$110=8000.000 (x max rate, mm/min)
$102=188.976 (z, step/mm)
$101=40.000 (y, step/mm)
$100=40.000 (x, step/mm)
$31=0. (rpm min)
$30=1. (rpm max)
$27=1.000 (homing pull-off, mm)
$26=250 (homing debounce, msec)
$25=750.000 (homing seek, mm/min)
$24=25.000 (homing feed, mm/min)
$23=3 (homing dir invert mask:00000011)
$22=1 (homing cycle, bool)
$21=0 (hard limits, bool)
$20=0 (soft limits, bool)
$13=0 (report inches, bool)
$12=0.002 (arc tolerance, mm)
$11=0.020 (junction deviation, mm)
$10=115 (status report mask:01110011)
$6=0 (probe pin invert, bool)
$5=0 (limit pins invert, bool)
$4=0 (step enable invert, bool)
$3=4 (dir port invert mask:00000100)
$2=0 (step port invert mask:00000000)
$1=255 (step idle delay, msec)
$0=10 (step pulse, usec)
[’$H’|’$X’ to unlock]

As far as learning, I am trying. Since deciding the buy a machine for the robotics team last fall, I have spent well over a hundred hours reading and learning. There are really no good guides for a beginner, so even the process of taking files from Inventor (which I know very well) to a router table (which is new to me) was probably 40 hours of reading, trying, finding a new problem and then trying again. I just know that there is so much to learn, and one reason I chose this machine is Easel which helps the uninitiated get through some of the hurdles a little easier. It also has its limits, but you have to start somewhere. I am in the process of switching to the other computer and will report back on those efforts in a little while

Problem solved!! I tried the old computer and got the same error. No movement on x-axis with a message of a failed homing attempt. With the multimeter, I found that the x-axis limit switch was closed (compared to y and z which were open). Looking at the switch, I could see that the arm was mechanically stuck in the closed position. I think it was because of the way it contacted the trigger bolt. I exchanged the bolt for one with a larger head so that the limit switch reed would hit the larger head and trigger rather than keep trying because the carriage frame hit the spacer before the switch was triggered. It looks like it is working well now. Thanks for the advice


I need help also… I can’t get my X-Carve to home. I cleaned all connections, checked all limit switches. I finally got the Z-Axis to home but not X or Y. I don’t know what I did to get Z to work. It worked fine as I started the day but failed on my second carve for the day. I even went to machine set-up and went thru the homing process and the Z won’t respond there either.

OK, then what is the first step to start next project because I home every time… Would that be “Unlock without homing” by chance. Seems like I tried that one time and it went nuts…

OK. How about now. I get X or Y to move at all. The Z moves. I tried to start by unlocking without homing but I have shut it off numerous times because of my issue with homing.

Sorry, I can’t get X or Y to move

I took connections loose and checked with meter for operation and they are good. I even pulled all the connections loose on X-Controller and checked them. None of them worked and I don’t know what I did to make the Z to start working.

Funny thing is, it all worked just fine for my first carve today and then I went to start my second carve and then the problem started.

Please help… I don’t know what to do. I am down and need to get back at it…

I guess it needed a day off… It’s working fine this morning…

Can you tell me how to jog the spindle out of the way to change the material and then manually home it back without turning X-Controller off?

I don’t know UGS. And, by the way, I just got thru with my first carve and turned it off and now it will only home the Z-Axis and not X and Y. Same problem as yesterday…

10-4. I’ll try that if I can get it to working again :o(