X axis non working

so i had my x carve working perfectly. i turned off and re routed some cables and now x axis will not respond . all power was off i have triple checked every thing multiple times and nothing . only two of the green light come on g shield .all flicker when move manually .help??


When you re-routed the cables did you disconnect anything, or just move the wires around?

With the power off (USB cable unplugged and the 24 volt power supply off) swap the X axis wires with the Y axis wires at the gShield. So, now X is Y and Y is X.

Try the machine and see if X and Y work. If yes, then put the wires back the way they are supposed to be (with power off, both USB and 24 volt) and see what works and what doesn’t.

If no, then which axis works and which axis doesn’t?

hi larry
thanks for your assistance . yes i disconnected x y and z from g shield. usb ans all power was off . hooked back up as i had it. even checked and went through all instructions 3 times so far. will try as u advised . thanks again

ok changed seems to be x in g shield that not working ?

So, when you swapped X and Y, the problem moved to the Y axis and the X axis worked?

And when you swapped them back, the X axis didn’t work, but the Y axis worked?

hi larry
i moved x in to y in g shield and works but nothing in the x in g shield seems to work . faulty g shield?

Yes, I think so.

By moving the wiring you proved that you don’t have a problem with your wiring and most of the time this problem is the gShield if it’s not the wiring.

The only other thing you could try is a different Arduino (not likely the problem but it can happen) if you have one laying around.