X-Axis not Microstepping, NOT Pot/Ecc. Nut/Tight Belt

I tried microstepping the X-axis while homing a project today (0.01"), and all it would do is sit and shake back and forth a little bit. It moves in 0.1" increments, but not 0.01". This happens anywhere on the X-axis, not just in one small area. In my latest project, I’m carving some holes 0.140" to hold my bits and the holes are oval shaped, longer in the Y axis than the X (but slightly rotated, pointing toward 12:30 or so).

X-Axis Belt: I loosened the belt up a lot, more than I’m really comfortable with, and there was no change.

Wheels/Eccentric Nuts: I inspected the X-carriage wheels and re-set the eccentric nuts (loosened, then tightened) with still no change. No debris in the wheels or on the belt.

Pot: With the belt loosened, I checked the X pot and tried adjusting it while trying to microstep. No change, even with it dialed up all the way. Vref was originally 1.6 VDC, was a LOT higher when fully turned. I turned the pot back to 1.6, matching the Y and Z axis.

To summarize, the X-axis stepper works fine unless it’s trying to take microsteps (~0.01"). It’s not due to a tight belt, eccentric nut, dirty/bad belt or track, or a low pot setting.

Any ideas from the braintrust before I consult with Inventables? I haven’t seen any posts about bad steppers, and I’m not overly concerned because I am still doing large projects where there is lots of slop. I would like to try to resolve this before I start trying to play with engravings though, and I have a few projects planned where it could start to present a problem.



Could be a pot setting. With a Vref of 1.6 volts you’re pushing 2.0 amps per phase (1.6/0.8=2) . If you are using the gShield its max current is 2.5 amps per phase with “appropriate cooling”. If you are only using the Inventables fan that is not “appropriate cooling”. You could be getting into the thermal shutdown region of the driver chips.

Does the problem only occur on the X axis?

As a test you could back off the 1.6 volt Vref to get a smaller current limit just to see if that helps.

Only the X-axis. Backing it down to about 1.0 got the same results, no microsteps.


That’s odd. If the Y axis is doing microsteps, but not the X the only difference that I can think of is that since the Y axis drives two motors, each motor is getting half the current. Since you’re running 2 amps per phase on the Y axis that would give each motor approximately 1 amp per phase.

With a Vref of 1.0 then you are pushing 1.25 amps per phase on the X axis. I don’t know if that’s enough of a difference to be significant or not.

Just re-read your post. Did you check to see if the pulley is tight on the motor shaft?

I just checked it, the screws are both in tight and one is dead center on the flat. When I try to move it, it looks like it tries to turn a little bit and then turns back. If I didn’t already have the belt loose to the point of slipping, I’d think it was a tight belt. It’s a lot looser now than the Y belts, which are still microstepping like champs.

Swap the x motor for one of the y motors and retry… If that doesn’t help than set all tensions etc to same as y and reload grbl onto the arduino and redo the setup in easel

i had this same exact issue. i made a post about it awhile back. never figured it out but then the problem just disappeared. sorry thats not much help