X axis stepper not working

after two weeks of husseling with the x carve setup I have disided to look for help from here.
After setting everything up I got to the point of testing all axis with Easel. Y and Z worked perfecty but X doesn’t respond to any commands. It only jerks in a random direction with small steps. When I connect the xcarve to my mac then at first all three axis LEDs go green and in a second the x led starts flickering and wont stop until I power off.
At first I thought I have a broken stepper motor. Then I tried connecting Y and Z axis steppers to the X port on gShield and the same problem happened with the other axis.
When I connected X axis stepper to Y or Z axis port on gShield then it was working perfectly.
I know that the problem is not in the wiring or with the stepper motors.
Then I thought that I might have gotten a broken gShield.
I contacted Inventables help and they thought the same and sent me a new one. After allmost a week of waiting I got the new gShield and was hiped to start actually working finaly but nothing changed with the new gShield.
Then Inventables thought that I might have gotten a bad spindle that couses problems with the stepper control. I dissconnected it as they recomended but still nothing changed.
Now I have gotten to the point where I have no idea what to do next.
All the wiring is done correctly and checked atleast five times and yes the gShield is inserted properly to arduino.
I don’t know if this is a common problem or not but I hope that there is someone that knows how to help me

Below I have posted a few links of videos showing to you what is happening with the steppers and gShield:

Go to the Machine Inspector in Easel and get the grbl parameters and post them here.

If the wiring is correct and you don’t have any wire strands touching the neighboring terminal connections then it could be a software issue, either in the grbl parameters or you may have a bad grbl install on the Arduino.

Your first video shows that your belt is not tight enough. You can see the belt lift away from the pulley in one spot.

The two gShield videos show that the X axis is receiving step pulses.

Those parameters are good.

Do you know how to re-flash (upload the grbl firmware) the Arduino?

See video comment in my last post.

To me it looks like a loose connection or bad wire, I would try hooking the stepper directly to the gshield and bypassing the wire that you connected and rule out the chance of a break in the wire. Early on I found the wire to my Z stepper had a break in it. You could also use a multimeter on continuity but if you have the patience to undo the stepper and go direct to the gshield it’s more reliable.

as I am new to arduino and all that staff I have no idea how to re-flash the arduino

As I have connected the x axis port on gshield with other steppers aswell, I can be sure that the problem is not in the wires.

Here are the instructions for updating the firmware:


so now i re-flashed my arduino but still no changes and yes, I know that my belts are loose. they are so because i was testing the steppers and didn’t see a point to tighten them up before I get the steppers to works propperly.
Is there anything else that I could try?

Check your $$ output from grbl to see if you get the same values that you posted above.

I know it has been beaten to death, but if you are confident in your wiring ---- then I guess the next step would be to replace the Arduino.

Did you try increasing your current for the x-axis wire in the g-shield?

Have you solved this problem?

Inventables sent me new electronics as we couldn’t understand where the problem was. It turned out that the problem was in the arduino as it was the only thing that needed to be changed to solve the problem.
every thing is working fine now