X Axis stopped working after firmware update

So I just updated my xcarve with the new firmware and for some reason all of a sudden my x axis is not responding. Has anyone else had this issue or know how to fix it?

What firmware were you running? What firmware did you upgrade to?

Does the X axis not work at all, or does it not function properly?

I will have to check in a bit what firmware it was. It does not respond at all… Was working fine prior. Y and Z work fine.

Did you rerun machine setup in Easel after upgrading? Did it work there?

yes that is what I was in the middle of. when it asks to make sure your machine is wired properly. the x axis will just not respond

Go to Machine Inspector (Machine -> Advanced) and enter in $$ in the Console and copy the response of your GRBL variables.

Here is my firmware and easel
Firmware Version: Grbl 1.1f
Easel Driver Version: 0.3.5

So I figured out apparently a wire came loose in the control unit. So I reattached that, it now responds in the setup but will not respond in the homing sequence. the z homes and then nothing. When I skip the homing all together it says it is all setup but when I go to do a test carve none of the motors respond. I am not sure what is going on. It was working fine a day ago.

I am going to try and reflash grbl and see if it maybe was a glitch in the system or something

I tried the $$ and when I click show status I just get an unending ?

The user interface between the GUI senders (Easel,UGCS,PicSender,Chillipepper, etc.) and grbl changed with grbl version 1.1f

You need to make sure that you have updated your G-code sender to one that supports grbl 1.1f

ok so re flashed to an older version of grbl and that seemed to do the trick except that when I went to home the router it literally smashed my z switch to pieces. besides that it seems to be working fine. I have to order a new switch though in order to test whether or not I fixed that issue

That’s what I bought.

I am having the same issue. Where can we go to update the G-code sender to one that supports grbl 1.1f?

Currently running with this copied from the machine inspector:grbl 1.1f and easel driver 0.3.7

Which older version did you reflash to that worked? Thanks

Depends on the G-code sender that you use.

PicSender 2.7.5 supports 1.1f

UGCS nightly build supports 1.1f

Here are the grbl versions that Inventables supports: