X-axis stopped working; not driving x-carriage


My X-axis motor no longer moves the x-carriage. The motor spins and makes a whining sound, but it no longer drives the x-carriage. What happened: I was changing a bit with the gShield powered on. I used too much force and the x-carriage overcame the “lock” and moved. Now, I am able to freely move the x-carriage even with the gShield powered on and the LED lights do not blink when I do so. Y and Z axis motors work fine. I checked the set screws on the pulley, adjusted the belt tightness and v-wheels, switched the wires with the Z axis at both the gShield and on the panel at the back of the x-carriage, and also tried adjusting the potentiometers. The motor does the same in all cases, and the Z motor wires are able to control the Z axis correctly when connected to the “X” inputs on the gShield. Is it possible that I messed up the motor when I was changing the bit or is there something else that could be wrong?

See video.

Thanks in advance,


Looks like a set screw in the pulley loose.

If you move the carriage manually goes your little flag turn ?

1 Like

It’s hard to tell from the video, but it appears that you can see the “flat” on the motor shaft and it’s not rotating when the flag is.

Check to see if the shaft on the pulley side of the motor is rotating when you have the motor on.

Thanks for the replies!

@FabianSubia: No, the flag does not turn when I move the x-carriage manually, and the gShield LED does not light up either. It does turn when I move on the Y-axis and the gShield lights up in that case.

@BobJewell: I checked the set screws again and it’s still not working.

@LarryM: The shaft on the pulley side moves a tiny, tiny bit every now and then, but it generally doesn’t move when I try to jog the motor. It did move more sometimes when I loosened the belt a lot, but it was still inconsistent and didn’t move as much as it should have. The belt also seemed way too loose at that point.

when I say manually I mean if you grab the carriage with your hands and push it, not like manually with the buttons.

Correct. The flag doesn’t turn when I push the carriage with my hands. And the carriage moves freely when I manually push it with the power supply is turned on. It no longer “locks”.

You have a bad motor.

Ok, that’s what I thought. Thanks for confirming. Can I use a NEMA 23 with my existing 17s or do they all need to be the same type?

You can mix them up. Just remember that the NEMA 23s can draw more current than the 17s. You may have to adjust your current limit, but it will work fine.

[Edit] - You should have the same type for the two Y axis motors, but X and Y and Z can be different.

Ok, thanks for the info, Larry!

Yes, I recall one recent and another one from a little good while ago. It can happen.

Bob, I appreciate your help. I didn’t have the second part of the info until I tried messing with the set screws again, like you initially recommended.