X-Axis suddenly stops responding

Hello Everyone,

So I am at a loss here. I have been using my XC 1000 for just over 2 years now without a single issue. I now suddenly go to use it and notice that on the second pass it no longer tracks on the X-axis and simple moves up and down on the Y. Upon inspection, the X-Axis completely stops responding, i can’t jog it at all. Shutting the machine off and back on will again have it respond. I can rehome the machine and try again.

However, the same thing occurs on the first pass.

I have spoken to inventables support and we performed some troubleshooting:
run air carve to test spindle interference - didn’t help
Reupload firmware - didn’t help
Swap z and x cables to check the connections - didn’t help
adjust voltage after the x axis fails - didn’t help

They declared my x controller to be faulty since the voltage didn’t help at all. After receiving a new one and replacing it, same issue.

I then swapped the USB Cable - didn’t help

Maybe the stepper was faulty so I…
Took the x stepper motor off and replaced it with the z stepper - didn’t help
Used Z cable on the X axis (yes swapped it both on the motor and board) - didn’t help

Maybe its the computer…
Plugged and configured it into an entirely new computer - same issue

I am at a loss here…

Did you check the wiring for the x axes maybe you have a broken wire?

Yes. All connections are checked and tightened. When it returns after I stop the cut, it homes on the Y-plane but not the X. Powering off and on the X will respond again. I can then start the cut once more, without homing the X and it will move, but then suddenly stop responding again.

Thinking it was a cable, we swapped the X and Z cables (z working perfectly). The Z axis was still working fine (with the X cable) but the X axis (with the Z cable) again stopped responding.

It was just a thought. I am sure someone smarter then me will chime in.

Here is a video of what happens

That is pretty wierd.

First guess: damaged or loose wires on the X motor.
Can you try the same job 6in to the right?


I decided to test some positioning. I started the x and Y at 0 and moved it up-left-up-rtight-up-left-up-right etc etc…

It would seem that around the 17-8" mark, the X axis loses ocnnectivity. I tried this a few more times, but it would then go all the way up to 30" without issue. On the way back down however, once again, at the 17" mark, it lost connectivity.

If I restart the machine at this point, I do not regain X axis

Blockquote Can you try the same job 6in to the right?

I have tried this and the same happens. This is why we swapped the Z cable and X cable. The same behavior would not happen with 2 different cables, and 2 different stepper motors.

I am wondering if its a firmware issue, but am not sure how to downgrade the firmware.

It’s just grbl… Probably millions use the same firmware.

She’s the controller still show the axis as moving? When it fails, check your wire continuity.

1 Like

Never trust visual inspection alone, do a proper continuity check using a DVM etc.
Fail points may be hidden under crimping/shrink wrap.

So after my tests with positioning, I decided to take apart the drag chain and check the wires. There were no visible kinks or marks so I did some more testing and saw a number of perfect air passes. I swapped the Z and X steppers as well as the wire assemblies. I decided to try a real carve. the first pass was great, it cut the piece perfectly. When it move firther into the bed to do the next piece, it again cut it perfectly… However…

It went to move to the third piece and the Z failed! It tried moving through 3/4in ply wood with the z all the way down! I have to conclude at this point, that its the X wire assembly (since its now on the Z). Moving it in the drag chain, I suppose, changed the point in which it now failed. I have a new wire harness coming today and will retry everything.

1 Like