X axis will not engage after setup/assembly

Hello, I have just setup up my X carve. it is the 750mm rail kit. I have had success with the Y and Z, but not with X. The Y and Z will respond to the initial jogs correctly. X will not respond. I’ve tried to isolate from stepper motor back to controller board, but have not had a breakthrough. All wiring is verified to be correct. Any input or insight will be most appreciated.

Once you have verified the wiring to be correct and verified that the little green connectors are secured properly, I would reach out to customer service as you may have a bad stepper motor.

Thank you much. I will reach out tomorrow.

With the power off, swap the X and Z connections. Does the problem persist on X?
It’s rare that a motor would be bad. More likely the driver is fried. Even more likely that it’d be a wiring issue.

I just switched z and x in the back of the x controller. I could jog x and my spindle would adjust height. I then tried to jog z. No response from the x axis motor.

Are you sure the stepper wires are in the correct order?

I did verify