X axis works, Z axis kind of works, Y axis sticks and then everything freezes

Totally newbie here. Inherited a Shapeoko 2. Trying to do the initial setup. When I hook up the machine, I go to machine setup in Easel. I plug in the model, etc, and…

I can test the X-axis, I can test the Z-axis (although it seems to be spinning in the wrong direction sometimes… I’m only clicking one direction button but it spins one direction, then another). As soon as I test the Y axis, the Y motors move to the edge of the Y-axis and won’t stop unless I unplug it. It keeps trying to move continually. After that, the X and Z axes no longer function at all, and I have to start the machine setup in Easel all over.

The gshield and arduino had come apart during transport, and initially I was trying to get it working without realizing that… I only noticed when I moved the machine and the gshield lights flickered on and the motors moved a little bit… Hoping there wasn’t an issue caused by that. I took the enclosure apart and made sure everything was seated properly

When I first hooked it up to easel, it asked to do a firmware update, which I accepted but canceled when I realized I didn’t know any of the machine’s specs. I’m not sure how to undo/redo that… Machine>Advanced>upload firmware asks me for a hex file, but gives no option to upload one, not that I would know which file to use anyway.

Maybe aI need a total “reset” on the firmware for the arduino and the gshield, the control board seems to be the source of my problems… I’m assuming everything else is hooked up correctly as the machine was working previously.

Any suggestions?

Wires are all appear to be secure - just to make sure I reseated them on the gshield.

The previous user says everything worked fine, wiring appears to be correct, so I’m thinking it’s a problem with the controller.

I’m on a Mac, and tried to do a firmware update with Arduino software and then with the Mac hex uploader. Is there an easier way to do this? I get error messages… Arduino software says "WCO refresh must be greater than one. I get an error on the iOS hex loader that says “not in sync.”


I can get all of the motors to work correctly when plugged into the X on the gshield. So I don’t think it’s my wiring to the motors.

When I plug anything into the Y on the gshield and attempt a test movement, the board “freezes up” - lights stay on and I’m no longer able to move any axes.

So, the problem seems to be with the Y output on the gshield. It is a gshield v5b.

Not that anyone appears to be reading this, but for future troubleshooters, I solved the problem.

I think that when the Arduino and Gshield disconnected during transport, something went wrong. Probably didn’t help that I was attempting to use the machine with the two control boards half disconnected and buzzing and zapping… :confused:

The Y driver on the Gshield stopped working, so I thought the board was dead, but in the end, it was just the firmware.

For what it’s worth, I couldn’t get the firmware to upload following the instructions on the inventables wiki. The best instructions I found were here:


I didn’t have a PROG key as they show in their photos, but I did have to hit the RESET button on the gshield to get the firmware to upload. Without doing that, I was just getting a lot of error messages.

I tried the Arduino IDE and Hex Uploader for mac. Hex Uploader was easier and worked. I don’t know if I was doing something wrong in Arduino, but anyway…

At first I used the file called
That didn’t work.

Then I found the latest version, 9 something.

Up and running. And learning a few things along the way!

Oh and one last thing. Once I updated the firmware, the machine was trying to run itself off the rails! It would move very fast to the edge and then the motors would keep pulsing even though it couldn’t move because it had reached the edge. Everything moved too far and too fast.

I figured out that the steps/mm for X and Y were set to 758 or something like that. So I used the machine inspector on Easel to set them to 40.20 - at first it didn’t work. This was easy, just a matter of typing in $1=40.20 and clicking enter!

hey Nick I am really new - as you were, but my z axis is doing the exact same thing. It was working fine for a few months now, but on my last project it started acting weird. It looks like the y and x axis work but the z moves randomly up or down no matter which direction I tell it. Any suggestions?

A stepper motor require three things, besides power:
1 - Enable (set active)
2 - Step pulse (clock)
3 - Direction

The typical stepper motor have two coils that magnetise, equal two wire pairs.
If one of these four wires are broken then the motor will receive all 3 mentioned above, but lack the ability to control direction - and the motor will usually move in the direction of least resistance.

Check your wires for continuity, through their entire signal chain.