X-Carve 2.0 Major Issues + BSOD (Solved)

Ok so where do I even begin…

On initial install and set up, Easel connected as it should have after going through the machine set up. During the first test run of a simple 1.5" x 12" rectangle outline, the program was WAY off by roughly a factor of 2 for both x and y (resulting in what was going to be an over 3" x 24" rectangle ready to crash into my clamps).

After I paused the program in mid-run to diagnose, the X-Controller disconnected from my laptop and would not reconnect even after going through the manual port assignments etc. I went back and updated the CDM drivers which in turn, while restarting my computer, resulted in a BSOD failure during shut down. And I know what you are thinking; No, BSOD’s are not common to my laptop and no I have not installed any other hardware or software at all recently which would falsely make me accuse the X-Controller to be the culprit. Likewise, after the first disconnect, my USB ports refused to work for other external hardware (mice and printers) when I got frustrated and tried working on other projects,

After a 3 more subsequent BSOD’s and hours upon hours of computer diagnostics, firmware updates, USB power management modifications, etc etc etc just to fully make sure my laptop was in full working order - everything was back to normal and I could restart without BSOD… After plugging the X-Carve in, booting up Easel, and running that first test program again however, it disconnected and screwed my computer up back to the original state of hell.

I finally managed to reboot, connect to Easel, and run / tweak the 1.5 x 12 rectangle multiple times and found that if I decrease the size by roughly .5, it runs as it should meaning my X and Y motors are travelling by twice the distance they should in Easel (which is a separate problem to fix in my list)… but (big surprise :open_mouth:) the X-C disconnected while I was playing with the settings in Easel and here I am.

One thing I know for sure… Though the drivers state they updated correctly, “X-Controller” is not listed in my device manager as the troubleshooting states it should, it simply lists it as a generic “USB Serial Port (COM4)” which leads me to believe there is a computer to controller communication error.

Suggestions? I see a lot of topics with similar issues/solutions running the Arduino, but what about the X-Controller solutions? As an engineer, I like to think I have at least an educated state of mind dealing with technical problems of this nature but I’m on day 2 with nothing but failure especially when this thing is now BSOD’ing my laptop of which I have a lot of important work on.

Others with similar issues have had luck with a powered USB hub…

1 Like

I’m guessing that would keep access power running back and forth through the USB connection since it has it’s own external power source rather than relying on the laptop to power it? I’ll buy one tomorrow if there’s even a chance it would help, it’s not like they are expensive.

Could you provide us some background on the computer and OS your using. Steve…

  • Change USB cables if you have a spare.
  • maybe open the Xcontroller and make sure the internal USB pigtail is fully seated. While in there,just disconnect and reseat it anyways.
  • disable USB power management for your ports (don’t let Windows power the ports down)
  • USB2 or USB3 ports? Might try switching from one to another. I’ve personally seen some USB3 ports cause issues with USB serial ports.

So after two full days of banging my head against the wall and almost putting a bullet into my laptop, the solution was as simple as a powered USB hub. Just ran through my first trial with absolutely no disconnect issues… Steve Walker, you’re a life saver.

As for the X and Y travel - It’s still twice as much as it should be but I can probably figure that out through forum searches or the machine advanced settings tweak.

1 Like

Glad I could help. I sure have learned a lot from the helpful people on the forum.

Can you post your settings?

Anthony, your X,Y and Z travel are controlled by GRBL variables $100, $101 and $102 (x,y and z). When you run through Easel setup, it should have set these accordingly. If you did go through setup and it’s still moving 2x as much then you will have to tweak these settings in the advanced section.

If you search for fine tuning x and y there was a great video some one had posted showing exactly what to do and the math involved. https://m.youtube.com/watch?v=RvNsE-iNkqk Basically you take a ruler, metric was easier for me to get the accuracy dialed in, base 10 number system. You put a vbit or pointy bit in your spindle and line up the ruler with the spindle then jog as far as you can and still be on your ruler. I had a 600 mm ruler for this, started at 1m and ran the spindle 500 in x+(for you I would keep it small at first since your spindle goes to far). So if you go 100mm and the spindle goes to 200mm, you need to multiply your $100 value by .5. Then try it again and get more precise. Repeat for each axis.


If your GRBL is right, you may want to check the DIP switches for micro-stepping. This image from the instructions shows what they should be as defaults.

I ran through the setup about 5 times just to troubleshoot various issues but even after that, the x & y were always twice what they should be. I measured it just with a simple 1 inch jog technique to find that it was in fact 2x exactly so ya, long story short I just went into the $110 / $111 and changed both from 400 mm to 200 mm… Now all is right with the world.

That doesn’t seem right. $110/$111/$112 are setting the max rate allowed by motion. As Phil mentioned, $100/$101/$102 are the steps/mm that you should change.

You need to either calibrate your steps/mm and/or check your Xcontroller DIP switches for the microstepping value.

$110/$111/$112 will just limit your feed rate capability when carving.

My bad!!! Thats what I get for answering late at night!!! Phil and Justin are right $100,$101 and $102 are
the values that you want to change!!

Of course magic happens and now I don’t know what your complaining about :poop: