X carve connectivity problem

Hi Everyone is there a way to get rid of the xcontroller box on the X Carve CNC. It keeps losing communication to easel on the PC. It.is destroying virtually every carve. Is it just a case of the Xcarve being junk and should I just get another machine built using components from the XCarve or purchase another brand with a more reliable controller?

Machine was purchased in 2021 and has hardly been used. Have tried everything from multiple driver installs, new usb cables, direct connection to micro USB port inside X Controller, seperate power to supply to pc, router, X controller. Resetting power option on pc for USB port, closing all other applications and backgroundd processes to no avail.

Have tried it all besides getting a new X Controller box. Should i justtoss this piece of junk XCarve, it is not worth the aggravation anymore.

two things I don’t see specifically listed in your list of things you’ve tried that I often suggest first. . . An Externally powered USB hub that has it’s own 5V power supply plug that comes from an outlet. This combats a common issue of Laptops not outputting the full 5volts onto the USB cable.

And the 2nd thing is the USB selective Suspend setting that Windows set to Enabled as default starting in early 2020. Here’s some more info on how to disable this setting: How to Disable USB Selective Suspend and stop your CNC carves from fai – His N Hers Handcrafted

As for using a different controller, that’s certainly not too difficult of a change. You could reuse the power supply and simply use a Arduino/Shield controller setup similar to the older X-Carves. I suggest using fairly strong drivers though…

I have used a powered USB hub and have set the usb piwer option on the laptop. I am getting recommendations from another CNcC user group to toss the X Controller and got with a PlanetCNC controller option.

1 Like

Would the Daoki have strong enough drivers available?

1 Like

The drivers included (dvr8825) are slightly underpowered so youd want to upgrade those as well. There are other contoller sollutions, premade kits do get more expensive though and im not positive they would resolve your issue.

Many maby Xcontroller users run it with no such issues, and thats whats leading me to believe it must be something specific to your setup…

I just ran into this issue. It was very frustrating, troubleshooting from the laptop all the way to the controller, cables and all. The result was the surge protector. It was fluctuating for some reason(it’s just old, I feel the same way sometimes). I swapped it out with a new bigger one and the issues disappeared!

2 Likes