X carve looses position at 1 point in program?

I do not understand i have been trying to cut this sign for my dad for a week now 5 attempts and every time at about 88 -89% completed the X Carve seems to loose its position and eats the sign i am making…
(File attached)

Anyone have any ideas why? dose not mater the feed speed I run at I am using a dewalt spindle was running 30 inches per minute on my last attempt and it is always way late in the program that it somehow loose its X position by about 1 inch

I am not an expert but I think the oval cut out is the problem. if you select all and combine you see blank where as if remove the oval and select all and combine then the letters stay. If your letters come out good then split the job in two stages, remove the oval from the job in the first pass then repeat the job with keeping oval and remove the letters. I guess it may work. I think it has to do with layering in Easel.

It seems better but still has 2 lines running through it in odd places… there is 2 places where a line runs through the image and 1 place where it only cut 1/2 as deep on the bottom of the letters…

Hi all sorry to bump this up to the top again but this is getting really frustrating. i have attached another picture now it seems that the machine will only do machine 0 instead of home 0??? I know i set it i also ran the same program again that I listed above and when i was looking at the project 8% complete it has the same style double image going on…

Looks like it is missing steps on the X, same problem I have been fighting. Unfortunately there is probably 50 different reasons it can do this. Mine turned out to be both bad electrical connections and settings in software. Not to mention adjusting the v wheels and belt tension many times.

Having the same issues, have you figured this out?

If you’re getting double-images or dropped steps, I’d go through the usual steps:

check that your eccentric nuts/v-wheels aren’t too loose or tight
check your belt tension
increase the voltage slightly on your grbl shield by adjusting the potentiometers

Doing that typically clears up the types of issues you’re seeing.

Done ever single one of these numerous times. Started setting home drilling a small hole, then running the cut and stopping at the same point. X & Y always come back a few mm from home. Currently testing tightening the belt more between every cut. No effect. Adjusting voltage got me closer but if I go any higher I get thermal shutdown/stutters. V Wheels have been adjusted with the controller turned on per inventibles customer service. Every time though still a few mm off. I’m going crazy at this point.

You know that the v-wheels could be too tight, correct?

solved for me (kinda) I was playing around with the machine and i noticed that only in 1 position it seems to realigning itself right at the front edge… Not sure why, but if I start my work peaces at 3mm back the studder/realingment goes away… if the machine comes right up to the edge you can literally see the one side move while the other side stays…