X-carve motors not responding properly

I finally got my x-carve assembled and now I’m having issues controlling it.

I installed arduino and easel local. Easel setup sees the machine and goes to testing motors. The tests work intermittently. Only 1 or 2 axis will respond at a time, and not consistently work. Sometimes an axis will go up but when I press down arrow it goes up more. . .

Unplug/replug and refresh easel in my browser. Whenever I plug in the USB cable the machine starts twitching, usually on the z axis, and starts giving me a squeeling sound.

I have checked all wires, made sure gshield is plugged into arduino by removing it from the case and visually checking connections. Using a laptop so I tried a second laptop same issues. Both Windows 8 with current updates.

Led’s on the board light up when I move the axis manually with power off. Spindle is the only thing that works reliably when I use the switch. 1000x1000 fully upgraded setup with limit switches.

What steps can I take to troubleshoot.

Sounds like a loose connection on motor wires. I would check them all again. And verify they are all wired up correctly.

I agree with @ErikJenkins, also check to be sure one of the tiny cable strands has not escaped the connector and is making contact with something else. I had that problem with two wires when I first powered up and it caused very similar symptoms to what you are describing. I had to get a magnifying glass to inspect each connection to find the stragglers.

Might be G-Shield not pressing down to Arduino is the possibility. I put just high enough two plastic pieces over G-Shield, cross corners, when fan plate in place it’s pushing G-Shield down. I’m sure it’s not going anywhere.

i have checked the wiring 4 times now running from start to finish. After doing some research, i tried disabling my firewall. Now x axis works every time. my y axis is trying to move like there is a flat spot on a tire. goes smooth a small way then hits a bump of some sort. I disconnected the wires on both sides and tried moving it manually and same issue. I have all of the eccentric nuts in the loosest position, belt is pretty tight and cant see and flat spots on any of the v wheels.

With the y motors disconnected, i ran easel. z up makes z go down. z down does nothing. y up makes z move down and y down does nothing. really confused here. im going to recheck wiring again for a 5th time. Im wondering it its not the gshield or arduino.

If i leave the power supply on and usb hooked up. the machine randomly tries moving z axis. even when not on easel page.

Sounds to me like a connection issue between the Arduino and grbl shield, Are you sure all the pins are connected? Sometimes one or two pins will bend and not go in there proper hole on the arduino. Worth another check.

I double checked the pins. I have the boards sitting outside the housing. Visually checked connectors, all pins were seated properly, removed and reconnected for good measure and retested. No change. still having issues.

Looks like it’s time for you to send an email to Help@inventables.com. Might be a faulty board or something else. They will know. Sounds like an issue with the 5,6 or 7 pins that deal with direction as you can see on the pic below or the wiring, i could easily be wrong :slight_smile: but like i said email them they will know

I already sent them an email, but being Sunday i thought i might get help here on the forums.

Can you take a picture from the top of the electronics, showing all cable connections.

Not sure how to Imbed pictures. I followed the guide here on inventables and all connection match up except one. When wiring the axis the picture is exactly opposite the directions. Other than that everything should be done as its supposed to be.

The section I mean is under electronics step 6. It says from right to left but the picture is from left to right

Posting a picture is easy, just drag the jpg file and drop it on the message you are typing. You will see it show up in the window to the right of where you are typing.

horrible picture but exactly what is shown in the instructions. I do know the female plug that the power spindle and white limit switches looks loose. And it is. The connectors seem to big for the pins but the spindle turns on every time so I dont think its an issue. Ill replace the connectors later if needed

Oh yeah, good call, the second picture at http://x-carve-instructions.inventables.com/step14/#wire-stepper-cable needs to be rotated 180 degrees, or the text needs to be changed (probably rotated so the instructions match both pics). @ZachKaplan can you forward that request to the appropriate party?

It’s on my to do list when I get ahold of support in the morning. Only other issue I had was when it came time to cut the gray wires. I accidently cut the first 2 to 5.5 feet. Which is the 500mm size. I made due, but now my power supply is less than a foot from my machine. I’ll order more wire and get it fixed

One other test you can try is to unplug (with all power off - no 24 v no USB) the connector that has the homing switch and spindle wires.

Make sure that your spindle switch is in the off position. Power up and just run the Easel setup to the point you can test the motors for direction and see if you get different results.

Powered everything off and disconnected the plug altogether. Rebooted system and same results.

Ok, that says that your homing switches are not interfering with the motor controls.