X carve not close to cutting to inputed diamentions

Here is the deal. My x cave is not cutting close to the dimensions in my drawing. Example if i put in a square 2"x2" it will cut it to 1.964"x1.980" or a rectangle i want 1"x5" cut it .964"x4.973". It is consistent on these i have done each one five time and it comes out the same.

I sent 6 hours today checking every v wheels, belts, every nut and bolt, I went in and calibrated( found the video here) the steeps per mm in the X, Y and Z, it did fix the Z problem. The X axis moved 305mm when i told it to move 300mm fixed that. what i find strange is correcting that made no differance in the size of the square and rectangle size I mention above. I do not belive it is mechanical because it is consistent in size. I also tried to cut a square in Easel with the same outcome.

this is what i have or have done to my machine.
1000mm x 1000m
steel plate in between the X axis
turned up the pots
Dwalt 611
VCarve Pro
UGS v 1.0.8
Windows 10
64 bit

Now one thing i have with the UGS is that sometimes the steps in the manual move change on me ( this did it before Window 10) Example in inches i manual move it 1 it moves 1" run a cut path and then move it again manual 1 it only moves .10 inch, i need to up in 30 just to move it about 3".

I am very frustrated right now. What did i miss? or doing wrong.

Can you go UGS, on command line, type $$ and post the result, then we can see your numbers. Maybe something wrong with config values.

here is the command line for you.

Did you change your line $101. suppose to be 40. $102 is different, rest is same. $101 is your Y axis step count, $102 is Z step count. If you didn’t change those for reason, you may want to change it back and try.
$11 and $12 is important too, but I don’t see on the picture.

Here is mine;

$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.050 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=188.900 (z, step/mm)
$110=8000.000 (x max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=790.000 (x max travel, mm)
$131=790.000 (y max travel, mm)
$132=100.000 (z max travel, mm)

I did change $100, $101, and $102. When i first went in to check they were at factory settings.

This is what i did. I moved X over 30mm, put a ruler on the spoil board brought down Z with a v bit so i could get a point on the 0 on the ruler. Then i went in to the UGS, in macro and typed in for the X to move 300mm. It moved 295 so i did the calculation and changed the $100, now the weird part is it didn’t move to 300mm, so i tried a few different number and still no go, so i put $100 back to 40.00 and then it moved the 300mm. I did the same for $101 except it move 301mm initially, $102 ( cant remember its original movement its out in the shop) but these needed different numbers to move the Y 300mm and Z 30mm

Am I doing this correct?
What is $11 and $12?

I was thinking maybe your circle problem on the picture caused by Arc tolerances. $11 and $12 for that reason. Junction deviation is how fast you’re taking chips on junctions. I think you know what you’re doing. I’m surprised no one interest this problem on this post. Just give it a little bit time. Or you may call help@inventables.com.

I think i have it figured out. I believe most of my problems comes from the UGS or Java. From day one this have given problems from not completely downloading to the steps in the manual move or jog change on me. Example in inches i manually move or jog it 1 it moves 1" run a cut path and then move it again manually 1 it only moves .040 of a inch, i need to up in 30 just to move it about 3". So can it be consistent in steps in a cut path then? How and why would this change for no reason?

Im having the same problem @GiavonniPalombo Did you solve the problem?

Well on the jogging part yes, for some reason no matter what you need to switch form inches to mm back to inches and jogging works again as it should. PIA but beats changing the numeric to move any considerable distance.

The cutting not to dimensions, well i hope so. I’ve calibrated it for the third time today ,distance seem to change on me or im doing it wrong. If you calibrate use a caliper not a ruler. A ruler won’t get you even close. There to much to guess at, is it a 1/2 a mm or 3/4.

I checked for the fun of it and with vcarve pro, cutting a pocket it was off but cutting a profile it was .002 from the test squares i did. So im thinking a little is vcare fault, at least on pockets.