X-Carve not cutting correctly after initial test

Hi everyone! First post!

I finally got the XC all assembled and was doing some test cuts for practice and alignment.

The first cut was the “circle”, so obviously not totally perfect, but I figured that was an alignment issue, so i tightened up some belts, etc and tried again with the second cut of the triangle. Better!

I kept using the same project file, just deleting the old ones before making a new test cut.

I then tried cutting some text out, but this is when things started getting screwy. Instead of cutting out the word, it just sort of drilled three holes then gave up. Also the PWM motor control seemed to stop working (but continually works during the initial setup process, so I don’t think there is anything wrong with the connection)

so I tried again, and this time it just plunged straight down all the way into the wasteboard! (certainly proof positive to keep your hands out of the work area!). Does anyone have any suggestions? Are there some issues with certain browsers and easel? Does working in the same project over and over garble the g-code or something?

I haven’t tried a new project or a new cut yet since it went haywire.

Before you start a new cut, I would use the jog controls in Easel to test the X, Y and Z movements to be sure the mechanical and electrical components are all doing what they should be doing.

You can also tell it to jog a know distance and then measure how far it really moved to be sure the right grbl settings are loaded.

All of the movements have been fine, and even when the automatic spindle stopped working the X/Y/Z movements still continued to work. The accuracy wasn’t as huge of a concern for me as the huge freakout it did.

If the jog controls are doing exactly what they should and the machine is moving smoothly in each axis then the only other source of the error I can think of is with the gcode/tool path.

Are you using Easel to create your gcode?

Yes, this was all done from easel. The strange part was that it degraded over time (worked, worked better, then failed, then failed worse).
I need to try it from a different computer. The big “what if” was using it from Windows 10. I didn’t have a W7 or 8 machine at the time.

I cannot imagine a scenario where the OS (Windows 10) would cause the X-Carve to degrade or become unreliable over time. There are many ways that the Computer/OS can fail to establish a connection with the Arduino but that is either a working or not working.type of problem.

I would focus on your wiring, there may be a lose connection or a stray strand of wire making intermittent contact with something it should not be touching.

If there are no lose or bad connections then check to be sure the Grbl board is firmly seated into the Arduino.

You can also try removing the bit from the spindle and after making sure the spindle is high enough not to touch the waste board try a dry run of your test project again and see how the machine behaves. Listen to how the motors sound as they turn. If the machine is binding anywhere you will hear the difference.

Thanks for the tips! It might be a few days before I can get back to this, but it at least gives me a few things to try!

Hi again! It’s been a while since I’ve been able to spend some time with the XC. I sat down and redid the wiring, properly trimming the stripped ends, making sure solder joints were good, etc

Everything seems to mostly be running fine again! So that’s good news!

Now I only have to figure out what’s going on here. Would you think that it was a belt issue? I’ve been having trouble with final adjustments of the V wheels, tightness of the belts, and so o


I’m having the same problem that you described initially. I cannot get a perfect circle to cut. Did you ever find a resolution for your issues? Were you able to cut a perfect circle after adjustments?