X-carve not responding after failed firmware update

Yesterday my x-controller was doing a firmware update when something went wrong and it didn’t go through. After that my machine won’t connect to Easel anymore. I tried reflashing the Arduino but it also won’t show up in the Arduino IDE. I checked my ports and the computer does recognize the x-controller being connect to the USB. I’m running Mac Sierra.

I checked all the standard stuff, proper USB cable, power, drivers etc…, and nothing seems to make a difference. I also connected the USB directly to the Arduino. Tried some stuff from the Arduino forum but also didn’t work.

Could it help to do a clean instal of my OS and make a ‘fresh’ start? Does anyone maybe have an idea why my Arduino won’t show up in de IDE?


Got everything working again! Still don’t know what the exact problem was. Ended up trying 5 different MacBooks until I had one with El Capitan installed instead of Sierra. Arduino IDE found my x-carve immediately and was able to re-flash. Everything works fine again, also on my own Mac with Sierra.

Sorry for the fuzz :slight_smile: Hope this will help someone in the future…

1 Like

I’m more impressed that you actually had 5 different Macs to use. Sweet!!

1 Like