X-Carve PCBs w/Chilipeppr: bad autolevel results


I’m trying to use my X-Carve to engrave PCBs. I’m using the same toolchain that was used in the PCB walkthrough on this site: Eagle -> FlatCAM -> Chilipeppr. I have a z-min probe wired up to the X-Carve, and the probe is working correctly. The autoleveller in Chilipeppr runs w/o incident, generating height levels across my PCB blank.

The problem is that after I run the autolevel, and apply it to the PCB gcode, and then engrave the blank, I get consistently poor results: the engraving bit is being lifted off of the surface of the PCB in the same place across many PCBs. I’ve run this test a half-dozen times on different blanks. I’ve tried every 3, 4, 5 and 5 mm.

My blank is well secured to the bottom board. I’ve tried several methods, but the last few times I’ve done this (browser is google chrome on Windows 10):

  1. Drag the PCB gcode from FlatCAM into Chilipeppr
  2. Home the machine (using limit switches)
  3. Move the bit down to 3mm from the PCB surface
  4. Run the “Test probe” action to bring the bit exactly to the surface
  5. In the Chilipeppr Axis controls, zero out the Z axis
  6. Move the bit up 3mm
  7. Start the autolevel job
  8. When autoleveler ends, view autolevel results
  9. (Note that the button to “view autolevel results” brings up a window, but the button to “view autoleveled gcode” does nothing, which I assume is a bug?)
  10. Load autoleveled gcode into the workspace, scroll through the results to confirm its been applied
  11. Start the job

I’ve attached images below of two PCBs:

Autoleveling OFF (just zeroed with “run test probe” and started) shows the copper correctly engraved:

Autoleveling ON shows that the copper has not been fully engraved away: