Inventables Community Forum

X-Carve Pro Driver Issue

Setting up the Pro and made it to the connect to Easel section. Plugged in the new USB and got the message in the picture. Try to update the driver and it says it is the most current copy. Any clues?
image

I would start with shutting down the computer then restart and see if it finds it.

Yes. Did that as well and same message appears.

Thanks

Please contact the Inventables tech support team. They can help troubleshoot this with you.

I just forwarded this over to our team and they will be reaching out ASAP to get you up and running!

Thanks everyone for the help. I talked with customer support on Sunday and Giovanna Diaz Fabiani with the support team was able to help me find the issue. It appears my new laptop would not recognize the driver for the USB cable. I used my older laptop and it worked correctly. Thanks for the help and please close out the topic.

1 Like

I also ran into an issue with the drivers… not quite the same issue, but similar.

Installed the easel driver… said it was successful. However, easel wouldn’t talk to it.

Comes to find out, i needed another set of drivers… I can’t remember what it was, but i found it by going into my computers device manager, and then seeing an item that had the question mark.

Just googled that (I believe it was called: F232R USB UART)…

Led me to this url: Installing the FTDI Driver (Windows only) – Inventables

Installed that, and voala… Easel was able to talk to my new XCP.