X-Carve Pro not working

X-Carve Pro not working.

I have an XCarve Pro, using Easel Pro. Using a mini-PC, with an ethernet cable to the router.
I have had the machine stop many times in the middle of a carve. Sometimes I can restart the carve and continue, sometimes I cannot.
I have been doing some 3D carves by sending Gcode to Easel Pro. But still using Easel Pro to make profile cuts.
I finally disabled the USB Selective Suspend the night before. I thought it was solving my problems.
Yesterday, I had many issues of stopping during the carve. I finished one carve, then I was going to start another one.
Then, I looked at my spindle and it was slowly turning by itself. Slow enough I could stop it with my fingers. This made me look into all sorts of trouble shooting such as turning off the computer and the Xcarve controller many times, unplugging all cables, etc.
Nothing.
Then I noticed that the spindle was turning fast, but still able to stop it by hand. Then I noticed it is turning backwards.
Then I tried reloading all software for it.
Nothing.
Then I uninstalled the machine in Easel Pro. Now I am unable to re-install the Xcarve Pro back into Easel Pro.
I don’t believe that I have changed any computer settings that I should not have.

Any suggestions?

1 Like

clear your browser and cache along with your history and try again.

Tried that. No luck.

I think it has to do with USB or Comm ports.

try to reinstall the driver located in the machine dropdown

Done that numerous times.

Looking at my computer ports now, and ensuring that Windows is correct.

Let me just start by stating that one should NEVER EVER EVER grab the spindle of a machine that is being controlled by hardware/software unless that person has physically removed/separated the ability for said hardware/software to rotate the spindle automatically unless that person is trying to lose fingers/a hand.

Typically, the machine stopping mid-carve is going to be a noise issue specifically on the USB side. I know some people have had luck rerouting the internal USB cable (early X-Carve Pro controller internal wire management was not great IMO) away from the VFD inputs/outputs.

If the spindle is spinning with no command from the control board, this is likely a VFD issue (most likely a setting issue).

Either way, I would definitely contact Inventables support to get their assistance in this scenario.

{:0)

Brandon Parker

3 Likes