[ X-Carve Setup ] Blinking Green Lights?

Hello -

I have had no luck connecting the X-Carve from two different Mac computers. From “Enter your machine details”, I never get past the “Connecting to X-Carve …” prompt. It just hangs with no response.

I have looked over the various related posts but have not found a solution. I have switched to a Windows partition on a Mac to see if I have any better luck.

I now can get to where the 3 green LEDs blink every second or so when I click “Confirm Settings”. So there is definitely some communication. However I never advance past this stage.

Any thoughts? Maybe I just don’t have the correct firmware on the Arduino (I have not changed it from how it was shipped)

Thanks

Have you tried all the USB ports on the machine, making sure that you see the arduino (port) show up in whatever Apple calls the device manager?

@AdamLassy

If your serial port is not set for a baud rate of 115200, set it to that baud rate and try again.

Thanks for the the response Darryl: I switched back to the Mac environment and tried everything again. Yes, I can see the device in both ports under “System Information”. I was also able to see the device under the Arduino IDE. Same behavior: when I click “Setup”, I see all three green leds blink, then nothing.

Verify that the g-shield is properly connected to the arduino.

@ErikJenkins Thanks - Yes, it is seated correctly. I took the Arduino and shield out of the enclosure to be sure.

@LarryM Thanks for suggestion: I am now looking into how to do this in OSX.

Thanks

1 Like

Thanks Phil - I tried this but was not sure if this was only a local change to the Arduino IDE, or if it would also change the speed that Easel connected with. In any case same results: I set the speed in Arduino IDE, then closed program, closed browser, re-opened browser, tried to connect via Easel and same thing: Green lights blink once then nothing. (I also tried cycling the Arduino before re-opening the browser).

@AdamLassy

You need to set the speed in the operating system so that when you look at the properties of the serial port it shows up as 115200.

It depends on how a program is written, but you can change a port’s characteristics on the fly from software. A lot of programs don’t do this, and just default to whatever the operating system has set for the port.

Once the port is set, then you also have to tell some programs (Arduino IDE, UGCS, etc.) what the baud rate is that the port is expecting.

The shorter answer is it should be set the same in the operating system and the program accessing the port.

Thanks Larry - trying to find an example of doing this now.

In case anyone else has already struggled through this, I am attempting to set the baud rate of the device after connecting the Arduino, using stty on a Mac:

stty -f /dev/tty.usbmodem1411 speed 115200

However this does not change the baud rate. Larry, from what you are saying i’m getting that the Easel driver will not be able to set the baude rate and it must be done in a global way outside of the software? Arduino for example can set the baude rate to whatever the hardware is expecting.

Thanks

You should be able to set the baud rate in the Arduino IDE in the Serial Monitor. There is a dropdown menu that let’s you select it. (Good page here on that topic - https://learn.sparkfun.com/tutorials/terminal-basics/arduino-serial-monitor-windows-mac-linux)

Once you have that set and have opened a serial connection, you should see GrBL information coming through the console.

I had a very similar problem early on that was entirely the result of the software trying to access the XCarve on the wrong port. Using the Arduino serial monitor through the IDE was the solution that worked the easiest for me.

1 Like

Thanks Roger - So looks like I may have a bigger issue: when I connect via the serial monitor at the correct speed I just get garbage back. I think I’ll start by flashing the Arduino with the firmware in case it was shipped without.

Thanks

I don’t have any Apple equipment, so I can’t help with that or test it.

However, I did check it out on Windows 7.

It turns out that both the Arduino Serial Monitor and UGCS do change the baud rate on the fly and are independent of the COM port settings in the operating system. While monitoring the baud rate on the COM port where I have the Arduino attached (with the baud rate set at 9600) both the Serial Monitor and UGCS connected at the correct baud rate even though the COM port properties continued to report a baud rate of 9600. Therefore both the serial monitor and UGCS do change the baud rate to the specified value in their respective baud rate settings.

Since Easel doesn’t have (at least I don’t think it has — I don’t use it) a place to enter the baud rate I’m assuming that it doesn’t change the port characteristics and that my be why you can’t connect.

Since you can see the device using the Arduino IDE maybe that is a better way to test your machine. What happens when you open the Arduino Serial Monitor in the IDE. Make sure you set the baud rate to 115200 and the “end of line” condition at the bottom of the screen to “Newline” or “Carriage Return”

[Edit] - yes I think a re-flash is in order.

Thanks everyone for the help.

It seems to be as simple as I just needed to flash the Arduino w/ the latest grbl. Not sure if it was just shipped without or possibly the Arduino got hosed when setting up the wiring.

For anyone having a similar issue: great place to start is making sure you are getting gcode via the Arduino serial monitor.

Thanks

1 Like