X-Carve stalls after only a short cut

This happened to me twice so far. As I set up for a carve, the machine responds and reacts exactly as it should. The software seems bug-free.

I walk through the carving steps, hit “Carve” and watch it go. It raises up, rapids over to where the cut will begin, lowers down and moves about an inch and stops. The spindle is still on, the motors are not bound, not stuck, no electrical connectivity faults anywhere. It just. Stops. It’s like, “Nah brah. Ain’t doin it.” :confused:

I can quit the carve and the machine will go back home, I can start over again, but it will do the same thing. Once in a while it will move a little bit further.

A full quit and restart of everything fixed the issue, but it’s not the first time (nor will it likely be the last) that this happened.

I wonder if anyone else has had similar issues, and if so what the cause was?

Do u have xcontroller

Yeah, Mike I’ve had this happen. I pretty much got it down to two things. USB connection and brushes going out on the router.

When it’s USB I reset my USB ports, do a full computer restart and check the ports for dust. The signal to me that it’s USB is that the X-Carve just stops moving or makes jerky movements. I also, may need to consider a new cable, people have mentioned that they can go bad, but since I sealed my computer up better I haven’t had any issues.

The other option is when the brushes wear out the arcing interrupts the signal and the X-Carve stops carving. The finished cut prompt comes up on easel, but the router does not home itself it just stays exactly where it stopped. Even if the brushes are not bad enough for you to hear the clicking of them arcing, at least this has been the case for me, it was still them, I just turned the speed up higher and I could hear the tell-tale sound of worn brushes.

Another thing I’ve seen mentioned that makes sense is if the G-Sheild is getting too hot.

I don’t think it’s the brushes or the router at all. The router stays on and running, it’s the steppers that stop.

It’s almost like Easel is waiting for an “ok” from the first set of commands but doesn’t get it, so it doesn’t send the next set. Could be a dodgy USB cable, or maybe a failing Arduino or G shield.

Fortunately it seems like the problem doesn’t do anything that prevents me from starting over, like skipped steps would.

Have you tried exporting gCode to a file from Easel and run it with UGS?

I haven’t. I was pretty sure a system restart would temporarily cure the problem, and I knew that if I kept it in Easel and didn’t jog the machine I could just re-zero the Z and start over again. For whatever reason UGS is buggy for me in terms of resetting the axes. I don’t like to use it when positional accuracy is important.

Have you tried a new USB cable?

I’m not stuck on this being your issue, I just want to clarify. When it’s the router causing the problem, the router doesn’t turn off, it continues to run, just the steppers stop and Easel displays “Congratulations Your Project is Finished” or whatever is says. It behaves like the project was been completed successfully, but it could have only been moments into the cut and the X-Carve is just sitting there doing nothing, and did not return to Home. I can began the cut again, I have control of the steppers in the pre-cut setup and then have it freeze again when it actually begins cutting. This is with the 611.

But again that may not be your problem at all, I just wanted to be clear. :slight_smile:

BTW @ErikJenkins, have you had to replace your original USB cable that came with the X-Carve?

USB cables are notoriously flaky. I would try a different cable just to rule that out.

can you post the gcode so we can see if the error lies there

I have experienced the same behavior with my X-Controller.

  1. Everything starts normal
  2. Then everything stops
  3. Easel still shows the cutting progress bar
  4. Motors are still energize, spindle is still on
  5. Pressing the XControllers Pause button does cause the Z axis to raise and the spindle to turn off.

So I wasnt sure where the problem lied.
If it was USB (i.e. unplug) , Easel will popup the Carve finish dialog…
But that is NOT what happens. Easel’s progress bar stays up.
The X-Controller is not locked up because it response to the Pause command.

I think it is something in between.
More likely EMI and static.
The air has been dry, and I was cutting PVC; with dust vac collection. This is a recipe for high voltage static buildup
So I grounded the heck of everything.
What I think really helped was grounding around the dust shoe brushes themselves.
I need to do more tests, but that seemed to help. Right now I have wires everywhere, but it seems to work.

The indicator that static buildup was the problem was debris was sticking to the outside of the dust shoe’s brushes…
I think this buildup then dissipates through the spindle or something other path (from the stock to the machine?)

Anyway good luck!

Thanks for all the help guys. It’s always tough to diagnose an intermittent fault, and I haven’t ruled anything out yet, but for now a full system restart cured the issue. I imagine it was a bad connection between my computer and the Arduino. Whether that was caused by a bad USB cable, or by too much dust in the air, or by EM interference from the motor, who knows.

I do know that my spindle, the DeWalt 611, has been in operation since November without having any issues, so it may be time to replace the brushes.

1 Like

Glad you’re back in action Mike. There are so many ways things can go wrong, sometimes it amazes me that they ever go right.

My first cut this morning, after about 10 min. froze. I’ve made it a habit to set a witness point, so I just reset and finished the cut no problem. It cut the rest of the day, probably 6-7 hours without any issue. (If there were shrugging emoticon indicating “who knows” I would interject it here. )

You mean this one?


1 Like

OK, This exact issue happened to me yesterday.
I restarted my browser, and it carved 69% and then stopped.
Hitting the Carve Cancel button (the X) does stop the carve, and it returns home correctly…
So it I think it is a software issue.
My setup:
Easel, Chrome, MacOS X.
I can dig up exact software versions if required…

I hate intermittent faults. Ever since this happened I’ve been carving with no problems.

At least if it does happen again it seems that we can get the spindle back home, restart the machines and restart the cut without having to sacrifice the material. So we got that going for us, which is nice…