X-Carve stopped working, noise from motor

I haven’t done much with the X-Carve yet. Just a little engraving test and one speaker tray from soft wood so far. I planned a little dust evacuation system for the X-Carve and needed to mill some 5 mm aluminum plate for it. The milling went beautifully up to this point…

This is where the machine just stopped running and the stepper motors started to make weird noises. I can connect to the X-Carve, but it doesn’t move anywhere. This is how it sounds after powering up: http://discuss.inventables.com//discuss-assets.s3.amazonaws.com/original/2X/4/4a70b261f58236fae2139f3aa89aa801b617d711.wav

I think that at least most of the noise comes from the X-axis motor. Does anyone have any idea, what could possibly be causing this? I didn’t find any loose connections.

Ok, so the uploaded WAV-file doesn’t work. Thanks, Inventables. Here is a Youtube-video about the noise (power up, 40 secs, power down): https://www.youtube.com/watch?v=l5PoxNwYhS8

Edited to add: When I am in Universal Gcode Sender and click open to open the connection, the gshield fan speeds up for a second and the motor noise also stops for a second. But only for a second. Could this be caused by a defective 24V power supply?

Edited to add: The power supply seems to output only 6.7 volts and 24 volts only for a second or so when opening the connection from the computer. So I am guessing the power supply is the culprit here. I am waiting to hear from Inventables support.

Edited to add: When disconnected from gshield, the PSU output is 24.1 volts…

Try disconnecting the motor wires from the gShield. Hook the power supply back to the gShileld. Power up and see if you have 24 volts.

If so, hook up one motor at the time and check the power supply voltage after hooking up each motor to see when you lose the 24 volts.

Thank you! I tried this elimination game. If just the gshield is connected to the PSU (no motors), the output is 24.1 V. If any of the axes is connected, the voltage is just 6.7 V. So it is probably either the gshield or the PSU. No way to tell without spares to test.

Sounds like the gshield. Make sure your v-wheels are not SUPER tight. You might have drawn too many amps. Or, could some aluminum chips have found their way into your electronics?

Do you have two 12 volt devices you could place in series to put a test load on the power supply?

The v-wheels and gshield pots were both adjusted according to the build instructions. As for the aluminum chips… Not entirely impossible, though unlikely. I cut the motor cables exactly to the length that was specified in the build instructions and they ended up being a little too short for my taste. There is a piece of polycarbonate sheet between the table and the PSU and the PSU is sideways so that even if there was no sheet, nothing should fall inside the gshield housing. The PSU housing however… It’s not impossible. But if there was a short circuit, it should have blown the fuse, right?

Unfortunately no. I have an ATX power supply inside an .50 cal ammo can that I use as a desktop power supply whenever I need 5 or 12 V. But it can only output 12 V.

When you did your one at a time motor test did you try each motor on one position (X or Y or Z) or did you try each axis position on the gShield?

If you tested each driver position separately with only one motor (or the Y set) and you still lost the 24 volts then I would guess that the power supply is bad.

I tried each axis position on the gshield separately, but only X-X, Y-Y and Z-Z.

Ok. I still think it’s the power supply. It can deliver a light load and maintain 24 volts (gShield and fan alone), but when you load it down the voltage drops, but does not go to zero.

I hope you are right. I think I’ll buy a new (better quality?) PSU tomorrow. Or today, it’s actually 6 AM… This rail mountable 24 V PSU from a local shop looks decent: http://www.vekoy.com/product_info.php?cPath=71_2494_2498&products_id=14124

109 euros, ouch.

I hope so too!

You don’t need a 20amp supply unless you are going to run something else from it.

Depends on which spindle you have. If you are running an AC router then 10 amps would be plenty for the motors.

1 Like

I am using a Makita router, but I bought the 20 amp version anyway. After this problem emerged, I started to consider a more robust alternative to gShield and grbl. I have not read enough about those yet, but apparently this PSU should suffice in use with Mach3 and the like.

It turns out it was the PSU after all. I cut the sticker on the “old” PSU and took it apart (and no doubt voided the warranty, if there was any). I didn’t find any aluminum shavings, but that doesn’t mean that this could not have been caused by one of those. I also bought a section of DIN rail, so the new power supply is now mounted on the rail under the table and is thus better protected. I would have liked to mount the old PSU like this too, but I cut the cables exactly to the length specified in the build instructions and they ended up too short. The Y-axis cable is OK length, but the other two are too short.

This is a PSU family photo :smile: On the left is the new PSU, on the middle is the original POS lowest bidder PSU and on the right is my trusted desktop power supply (irrelevant to this case).

Thank you for your help!