X carve stops carving

My x carve suddenly stops. I am trying to resurface a 29" MDF slab and it stops a quarter of the way into the carve. Once it stops, a window pops up and asks how the carve went. Anyone know or can help me resolve this? Thanks in advance.

I was having similar problems and it turned out to be EMI. Once I installed a chassis grounds and installed chokes on all the stepper motor wiring and and the router wiring. I haven’t had any issues sense and it drove me nuts for about two months trying to figure out what was going on. Good luck!

1 Like

RF/EMI noise picked up by the USB link I recon.

Yep! Inventables didn’t even mention that either, I found that on the forum and YouTube. :thinking:

Would you be kind enough to illustrate on how I go about doing that and what I need to purchase please? Thank you.

  • Re-route the USB cable and keep it away from power cords / router cord.
  • Check the brushes on the Dewalt, these wear and once they are done RF-noise increase. Replace if needed.
  • Run Dewalt on speed #1, higher RPM = more RF-noise
  • Consider using an externally powered USB-hub, these reject noise better.
  • Flourescent lighting tubes (their starter primarely) can cause a lot of RF-noise.

Trouble-shooting can be quite tedious as the culprit most often hide in the details.


What he said and five pack of chokes off Amazon, four small and one large. I clipped the small ones around the stepper motors wiring near the motor and put one of the large ones one the router power cord close to the router. Grounding the chassis you just take GOOD braided copper wire, doesn’t have to be very big, run a soldiered end wire from the housing holding the router to the Z axis mount then jump that through the drag chain to the X axis then to the Y axis. Then from the chassis anywhere go to a GOOD ground. I was close enough to my ground stake that I ran a solid core wire from it into the shop to a bus bar then to the chassis. The photo split my writing! Sorry! If needed I can draw the wiring out for you but I think you got the idea. Rob

1 Like

1 Like

I am having this same issue and customer support is looking into my unknown error code. When it stops I use cltr/shift/D to bring up the machine inspector and the error says “Error writing to com (getoverlappedresult) unknown error 31”

From the stop screen it asks at the bottom how the carve turned out. if you hit the sad face it brings up troubleshooting but at the bottom it asks if you would like help from Xcarve. Saying yes to Xcarve help will send the error codes to customer support and you can leave your contact information for them to call you.

I mention this only because I am having the same issue and it’s not interference. I get an unknown error every time.

1 Like

Thank you! I’ll try that. I will try one more time to carve and if it doesn’t work then I’ll use this troubleshoot.

I appreciate it. Sorry, I haven’t got a clue on wiring/electrical trouble shooting. When you get the chance can you draw a diagram on how to ground properly? I’m a visual learner :blush:. Thank you

download (9)
if you need more detailed info send me a email or pm me gpa612010@live.com

I have been having the same problem. At first I thought it was easel, so I tried the carve again using UGS and it stopped at a different point.

Reading the message chain here, I’ve gone ahead and ordered new brushes for the Dewalt. I’ve had it almost two years, and was starting to wonder when those would start to go.

@RobertLBragg Robert, for that screen shot above from Amazon, that’s for a half inch cord. Would that be for the bigger power cords (all the 110v)?

If so, what size would you recommend getting for the usb cords? There are several sizes out there.


I finally figured out that the screensaver would come on when there was nothing moving on the screen and that made it stop the Xcarve. Once I went into the settings and changed it, the problem was solved.

Yeah, that’s another one. You have to go into computer settings and turn everything off, power management, display timers anything that might cause the the computer to send a mix message to the controller.
I finally got mine to the point that I can run UGS and a couple of other programs at the same time and it continues to carve fine.

Try 2 things. First make sure that your drawing is well within the perimeters of you material dimensions. If it detects that it’s at the end of your dimensions it will stop. Secondly I had the same issue and switched to Google Chrome. Problem solved.

Mine did the same , funny enough , I have connected the USB port from the X carve via a USB hub to the pc and problem solved !

I have had a similar problem. Found out it to be my wifi connection, dropped out. This was an issue in my house since so many devices were running over the wifi. The remedy was I ran a Lan line to my laptop and this solved the issue.

Easel do not rely on internet connection when sending gcode to the controller.
That is handled by the Easel Local driver.

Internet is only required to open/edit/save design in Easel.

1 Like

I thought it was strange that he would say that running a line to his computer solved his problem. I’ve actually turned my wi-fi router off while carving to see if it causes any issues and it didn’t.